If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird shutdown does not close all its Process Images correctly in 64bit Vista

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Ben Pintilie, Unassigned)

Tracking

({hang})

Trunk
x86_64
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

After closing Thunderbird the application does not always close correctly and stays open in process list.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Thunderbird and use it as normal for a number of minutes
2. Close the application using the X at the top right hand side
3. Try to open the application a little later (Cant give an exact time, you need to leave a few minutes at least...)
Actual Results:  
Error Message box appears.

Title: Close Thunderbird

Text: Thunderbird is already running, but not responding. To open a new window, you must first close the existing Thunderbird prosess, or restart your system.

Expected Results:  
Thunderbird should load.
(In reply to comment #0)
> rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

Can you reproduce problem with newest trunk nightly build?
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/
> Download win32.zip build. You can test by UNZIP only.

> Platform: x86_64

If problem due to 32bits Thunderbird is suspected, try 64bits version of Thunderbird. Official 64bits build is not available yet, but some builds can be tested if MS Windows.
> http://wiki.mozilla-x86-64.com/Thunderbird:Download
> http://www.start64.com/index.php?option=com_content&task=view&id=26&Itemid=75
> http://www.freeware.de/download/thunderbird-64bit_40625.html
(Reporter)

Comment 2

8 years ago
Up to now I have not been able to recreate the bug using the nightly build:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2pre) Gecko/20090721 Shredder/3.0b4pre

I will keep testing today and let you know how it goes.

Thanks for the information about how to use the nightly - never used it before.

Thanks
Ben
If you reproduce can you try to see if TB as still open connections to your email server using the netstat command ?
(Reporter)

Comment 4

8 years ago
Ludovic - I will do, at the moment I can not get the nightly to fail.

Do you want me to do a netstat on the other version that was failing?
(In reply to comment #4)
> Ludovic - I will do, at the moment I can not get the nightly to fail.
> 
> Do you want me to do a netstat on the other version that was failing?

Only on the nightly. If that does fail , it means the issue as been solved. if not then we need to know :-) 

Can you comment on the bug say in a week if you don't encounter that again ?
Version: unspecified → Trunk

Comment 6

8 years ago
I have often encountered this. It happened again with TB 3 beta 3 on a Windows Vista x64 system.
(Reporter)

Comment 7

8 years ago
Just installed Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

Will keep testing this version to see if I can reproduce the bug.

Chris - are you on the same version as mentioned in this message?

Comment 8

8 years ago
Hello, I have also experienced this failure of Thunderbird to completely quit. I'm using Thunderbird version 2.0.0.22 (20090605) on 64-bit Vista Home Premium SP2 to access my IMAP account. The only add-on I've installed is Lightning.

When I exit Thunderbird, either by "File > Exit" or with the red X button in the top right of the window, the UI disappears completely as if Thunderbird has quit, but "thunderbird.exe *32" is still in my Task Manager's Processes list. There is no icon in the system tray, unless I get a new incoming email message. In that case, an icon appears in the tray with a notification popping up that describes the new message(s).

I have not experienced the "already running" error described above; for me, double-clicking on my Mozilla Thunderbird desktop shortcut appears to launch (or relaunch) Thunderbird normally. The IMAP connection appears to have survived, though; I am not asked to re-enter my password (and I don't have a stored password).

As far as I can tell, there are not multiple instances running concurrently; looking at my process list, I've only ever seen one instance of thunderbird.exe listed at any one time.
All, it is useful to report the following aspects of your situation:
- is cpu high, low (non-zero) or zero?
- what does netstat show for imap and ldap connections?
- is Thunderbird's windows search (indexing) component enabled? 
  mail.winsearch.enable true or false?
- is gloda indexing enabled?  (it is not by default)
  mailnews.database.global.indexer.enabled true or false?
- is lightning calendar extension installed?

xref bug 420744 comment 41

bug list https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=anywords&short_desc=shutdown+exit+closing+close&product=MailNews+Core&product=Thunderbird&resolution=---&bug_severity=blocker&bug_severity=critical&bug_severity=major&chfieldto=Now&field0-0-0=short_desc&type0-0-0=nowordssubstr&value0-0-0=leak+crash
Summary: Thunderbird does not close all its Process Images correctly in 64bit Vista → Thunderbird shutdown does not close all its Process Images correctly in 64bit Vista
(Reporter)

Comment 10

8 years ago
Hey all, I can confirm the following.

Since installing Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

There have been NO repeats of the above bug.  I can also confirm that using version Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3 under "Windows 7 Ultimate" the bug is not in here.

I have tried the b2 under windows 7 Ultimate and managed to reproduce the same problem.  This leads me to say that the fault is now fixed with the new relase.

Please can anyone else confirm this?

Thanks
Ben

Comment 11

8 years ago
(In reply to comment #9)
> - is cpu high, low (non-zero) or zero?
The CPU usage of thunderbird.exe is zero.

> - what does netstat show for imap and ldap connections?
Here's the output of "netstat -b" at the moment:
Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    127.0.0.1:27015        Admin-PC:49158         ESTABLISHED
 [AppleMobileDeviceService.exe]
  TCP    127.0.0.1:49158        Admin-PC:27015         ESTABLISHED
 [iTunesHelper.exe]
  TCP    127.0.0.1:52550        Admin-PC:52551         ESTABLISHED
 [thunderbird.exe]
  TCP    127.0.0.1:52551        Admin-PC:52550         ESTABLISHED
 [thunderbird.exe]
  TCP    127.0.0.1:52552        Admin-PC:52553         ESTABLISHED
 [thunderbird.exe]
  TCP    127.0.0.1:52553        Admin-PC:52552         ESTABLISHED
 [thunderbird.exe]
  TCP    192.168.1.47:52555     mail:imaps             ESTABLISHED
 [thunderbird.exe]
  TCP    192.168.1.47:55364     sand:6667              ESTABLISHED
 [opera.exe]
  TCP    192.168.1.47:55537     www:http               CLOSE_WAIT
 [FrameworkService.exe]
  TCP    192.168.1.47:55580     mail:imaps             ESTABLISHED
 [thunderbird.exe]

> - is Thunderbird's windows search (indexing) component enabled? 
>   mail.winsearch.enable true or false?
I don't see that preference at all in Thunderbird's about:config.

> - is gloda indexing enabled?  (it is not by default)
>   mailnews.database.global.indexer.enabled true or false?
I don't see that preference either.

> - is lightning calendar extension installed?
Yes.

Comment 12

8 years ago
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

use 'thunderbird' instead of 'firefox'

when you quit, attach windbg to thunderbird.exe and use:

~* kp

attach the output.

Comment 13

8 years ago
I've never used WinDbg before; I hope I did it right. I put up the log at:
http://www-personal.umich.edu/~mikemorr/thunderbird-debug_118c_2009-08-10_16-22-55-344.log
Ben's problem is gone per comment 10, so closing

(In reply to comment #13)
> I've never used WinDbg before; I hope I did it right. I put up the log at:
> http://www-personal.umich.edu/~mikemorr/thunderbird-debug_118c_2009-08-10_16-22-55-344.log

Mike, please cc: on one of the other existing/possible dupe hang bugs and help out there once a fix is identified - bug 420744 or bug 494014.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Keywords: hang
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.