Converts all the phone numbers to links even if the number is already a link.

RESOLVED INVALID

Status

Firefox for Android Graveyard
General
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: mikepeterson, Unassigned)

Tracking

Trunk
x86
Windows Vista

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla Fennec-1.0a1.en-US.win32

Tried to test Fennec on our sites and found that it is trying to call the phone number even if the number is already a link that points to another page. IPhone has a special meta tag that turns off auto linking of phone numbers (<meta name="format-detection" content="telephone=no" />). 

Fennec need to support this meta or provide its own way to let webmasters to disable autolinking, otherwise it makes unusable some websites that lists phone numbers that are not supposed to be called by end users. 

Reproducible: Always
Mike, do you have a test webpage or url we can confirm this with?
(Reporter)

Comment 2

9 years ago
Just add the following code to any HTML page and click the link (i tested it again with fennec-1.0b3.en-US.win32 and it still works incorrectly). 

<a href="/somepage">800-800-8000</a>

When you click this link (IF you have SKYPE on your computer) it will open a window asking whether to call this number using Skype.

Also it opens this window if the phone number is not wrapped with the 'a' tag in the HTML code. As I wrote earlier, ideally it would be nice to have a special meta as IPhone does that disables autolinking of phone numbers.
We have an enhancement bug filed for this, actually.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437949
this isn't a duplicate.  Its a bug in the implementation from bug 437956, where we're just being too aggressive.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
we removed the code
Status: NEW → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.