Window.scrollBy method does not work.

VERIFIED FIXED in M14

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Prashant Desale, Assigned: joki (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] minimal window.scrollBy example.)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Window.scrollBy mthod does not work.

Providing information to simulate the problem.

Product: Seamonkey.[apprunner]
Build Date: 04/13/99
Platform: PC [Windows-95]

Steps to Reproduce:
1] Please copy the code I'm providing. Save as HTML file.
2] Open this HTML file in apprunner.
3] you'll find one button on tip called "Scroll Down".
4] Click that button.


Expected Results: As soon as you click that button, window should be scrolled
down automatically till last.

Actual Results: Window does not scroll down.


Code:

<html>
<head>
<title>Window Scroll</title>
</head>
<script>
<!--
function scrolltest1(){
for ( i = 0; i < 200; i=i+2) {
self.scrollBy(0,20)
}
}

function scrolltest2(){
for ( i = 0; i < 200; i=i+2) {
self.scrollBy(0,-20)
}
}
//-->
</script>
<body >
<form>
 <input type="button" name="testing" Value="Scroll Down"
onclick="scrolltest1();"><br>

	<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>
<h1>This is a junk text written here. This junk text is written in order
	to see the scroll bars.</h1>

<input type="button" name="testing1" Value="Scroll Up"
onclick="scrolltest2();"><br>
</form>

</body>
</html>
(Reporter)

Updated

19 years ago
Summary: Window.scrollBy mthod does not work. → Window.scrollBy method does not work.
(Reporter)

Comment 1

19 years ago
Window.scrollTo method also does not work. Since both methods are related, I'm
not entering seperate bug for it.

Updated

19 years ago
Assignee: vidur → joki

Comment 2

19 years ago
Didn't I see this yesterday? Hmm....

Comment 3

19 years ago
Created attachment 792 [details]
desale@netscape.com's test case as attachment for convenience

Updated

19 years ago
Whiteboard: [TESTCASE] minimal window.scrollBy example.

Comment 4

19 years ago
desale@netscape.com's testcase can not be much further simplified. Still doesn't
work on M7 and on 1999070917 build. For  complete bug report see desale's
comment.

Updated

18 years ago
OS: Windows 95 → All
Hardware: PC → All
Target Milestone: M14

Comment 5

18 years ago
This is broken on Macintosh today so changing platform/os to ALL.  Set to M14
(post-beta) since this isn't a crasher.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

18 years ago
I believe this may have just been fixed by Vidur.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

18 years ago
Tested with 10-09-09 builds. Working fine. Marking verified.
You need to log in before you can comment on or make changes to this bug.