Kannada(kn_IN) localized sessionrestore dtd typo makes it unrenderable

RESOLVED FIXED

Status

Mozilla Localizations
kn / Kannada
--
major
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Laxminarayan G Kamath A, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; kn; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; kn; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

A dtd typo makes the about:sessionrestore  useless as it jsut reports an XML error.I have found the bug, fixed it on my machine.. its exaplained in "Addiditonal Information"

Reproducible: Always

Steps to Reproduce:
1.open a few tabs with diffferent urls
2.  killall -9 firefox-bin 
3.about:sessionrestore

Actual Results:  
about:sessionrestore  ended with a report of an XML error 

Expected Results:  
about:sessionrestore should open normally with details of tabs  when firefox crashed

in  "kn.jar" , locale/browser/aboutSessionRestore.dtd  , the last line  makes the dtd's xml invalid ..
what is '& 37;S'  must be '&37;' .. I have tried  this fix on my machine and it works 
The two mistakes in the above string are  
1) 
 a space between '&' and  '3'
2)
a superflous 'S' 

Note : The  'S' in the comment preceding  the last line  is confusing. IThe author of theat line actually tried to  pluralize '&37;'.  I realized this  only becasue of my editor's syntax highlighting. ಇಲ್ಲಾಂದ್ರೆ ಹುಡುಕುತ್ತಾ ಮುದುಕನಾಗುತ್ತಿದ್ದೆ.

Updated

8 years ago
Component: Session Restore → kn / Kannada
Product: Firefox → Mozilla Localizations
QA Contact: session.restore → kannada.kn

Comment 1

8 years ago
I have corrected the error and committed the changes to mercurial.
Corrected file: http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/kn/file/9760a708e492/browser/chrome/browser/aboutSessionRestore.dtd

Comment 2

7 years ago
I think I have corrected the issue and committed the changes. Can we close this bug now?
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 545138
You need to log in before you can comment on or make changes to this bug.