Lists in Personal Address Book not migrating as lists

VERIFIED FIXED

Status

P2
major
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: esther, Assigned: chuang)

Tracking

Trunk
All
Other

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][PDTP2][rtm++] r=bienvenu+putterman, sr=alecf)

Attachments

(7 attachments)

(Reporter)

Description

18 years ago
Using 2000-08-28 build on win32, mac and linux migrated Personal Address Book
migrates a List as a Card  Note:bug 16422 for lists not being imported as list
is different from this one and is fixed.  Also this bug is mentioned in bug
45870 but is not addressed so I'm writing this new bug.

1. Migrate a profile with a Personal Address Book that contains lists.  Close
app and re-launch.
2. Open the Address Book and you will see Personal Address Book, but you don't
get a twisty indicating there are any lists.  Expand the Personal Address Book
and scroll down in the right pane until you see the list name.
3. Select it and click on "Edit"

Result: The 4.7 list is now regarded as a Card, Edit Card dialog comes up
Expected:  A twisty to show up next to Personal Address Book and when you click
it the list/lists you had in 4.7x show up as lists under the Personal Address
Book.  Also, when selecting the list in the right pane and clicking on Edit the
Edit List dialog should come up not the Edit Card dialog.

Result: in the Card view pane you will see the List represented as a card with
just a display name
Expected:  To see the List represented as a list
(Reporter)

Comment 1

18 years ago
marking as nsbeta3, this is part of migration and migrating Personal Address
Book loses data because lists have to be recreated by user in order to use them.  
Keywords: nsbeta3
QA Contact: lchiang → esther
(Assignee)

Comment 2

18 years ago
I have the fix for mailing list and it is part of the fix for bug 45870. Maybe 
we can treat this bug as a dup for 45870. 
Status: NEW → ASSIGNED
(Reporter)

Comment 3

18 years ago
Candice, I thought bug 45870 was fixed on 8-24 and this bug still exists with 
build 8-28 so that's why I opened it.  Let me know if I tested this too soon, if 
so I will mark it as dup of 45870 and retest when that bug is fixed.
(Assignee)

Comment 4

18 years ago
I haven't check in the fix for 45870 yet.  It should go in this week once I 
verified on all platforms.
(Reporter)

Comment 5

18 years ago
OK, to get this off the nsbeta3 list let's mark it as dup and verify it. 


*** This bug has been marked as a duplicate of 45870 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

18 years ago
verified as duplicate
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
Reopening this as separate from 45870 on Esther's suggestion.

Using september 14 commercial build, mailing lists still do not migrate.  The 

list name appears, there is a twist under the address book, but the list doesn't 

have any associated cards.  The list is regarded as a card, just as Esther 

originally described.



Status: VERIFIED → REOPENED
QA Contact: esther → suresh
Resolution: DUPLICATE → ---

Updated

18 years ago
Priority: P3 → P2

Comment 8

18 years ago
nsbeta3+, P2 - data loss.
Whiteboard: [nsbeta3+]
(Assignee)

Comment 9

18 years ago
Created attachment 15131 [details] [diff] [review]
Patch fot the fix

Comment 10

18 years ago
PDT agrees P2
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP2]
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta3+][PDTP2] → [nsbeta3+][PDTP2] fix in hand
(Assignee)

Comment 11

18 years ago
fix checked in
(Assignee)

Comment 12

18 years ago
resolved as fixed
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta3+][PDTP2] fix in hand → [nsbeta3+][PDTP2]

Comment 13

18 years ago
I'm reopening this bug. This is what I see using 2000-09-26-09-MN6 windows build 
on Win NT.

1. Migrates a 4.x profile. Launch AB (first launch). Shows 'abook.ldif' in the 
left pane. When I selected that nothing shows up in the right pane.
2. Quit and relaunch seamonkey again.  Open AB. Now I see PAB and CAB in the 
left pane. Select PAB in the left pane. All the cards and lists shows up in the 
RP. Select a list and click edit. I see only one entry in the list (I have two 
entries in 4.x).  This is true for another list also which has two entries, but 
only one shows up in the Edit | List window.
3. I selected the lists in the LP. Only one entry shows up in the RP. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

18 years ago
Keywords: relnote3

Comment 14

18 years ago
nom rtm for consideration.  Opinions?
Keywords: rtm
(Assignee)

Comment 15

18 years ago
I believe ther's a bug file for no. 1 (41887).  For list member problem,  I'll 
look into it.  It was working for me.  And yes, this should be fixed for rtm.

Comment 16

18 years ago
rtm+, data loss in migration.
Whiteboard: [nsbeta3+][PDTP2] → [nsbeta3+][PDTP2][rtm+]

Comment 17

18 years ago
PDT marking nsbeta3-
Whiteboard: [nsbeta3+][PDTP2][rtm+] → [nsbeta3-][PDTP2][rtm+]
(Assignee)

Comment 18

18 years ago
I can'r reproduce the lost entry problem.  I create a new 4.7x profile and have 
mailing lists with 2 or 3 entries.  It has the #1 UI problem.  You don't have to 
restart the app,  just reopen the address book window.  You still see the 
abook.ldif name, but the entries in the list are all there.  I'm using my debug 
commercial branch build on WinNT.

I will look into the "not shown" and name problem which I think it looks really 
bad on a rtm release.

Comment 19

18 years ago
I still see this problem in Today's BRANCH commercial release builds 
(2000-09-28-09-MN6). I'm not sure whether a release Vs Debug build 
matters. Candice, I can show this bug in my system if you want to.
(Assignee)

Comment 20

18 years ago
Please email me (or attach here) your 4.x address book file (.na2 file), you can 
find the filename by looking at the "ldap_2.servers.pab.filename" in prefs.js. 
Also the new addresbook.mab in your 6.0 profile directory.

I have the fix for filename problem(change abook.idlf to Personal Address Book) 
and the "not show" problem.  I will attached the patch. 
(Assignee)

Comment 21

18 years ago
Created attachment 15759 [details] [diff] [review]
Patch for fixing the "no show" and name UI problem

Comment 22

18 years ago
Created attachment 15760 [details]
4.x AB. pab.na2

Comment 23

18 years ago
Created attachment 15762 [details]
6.0, abook.mab file after migration.
(Assignee)

Comment 24

18 years ago
I tried on the release build (2000-09-28-09-MN6).  It works for me with 3 
entries in the list except those UI problems.  Suresh, can you try on a new 4.x 
profile.  I'll look at your na2 file.

Comment 25

18 years ago
I created a new 4.x profile (ab1) just now. Create 2 lists with 2 entries/cards 
in each. Migrated to 6.0 using today's branch commercial builds on win NT. All 
the lists and cards in PAB shows up. But the lists are empty. 

I migrated a 4.x profile (ab) that I created yesterday. Same case as yesterday. 
Only one entry in the lists show up. The other entry in the list is lost. 

I don't understand how this could happen between these two profiles. 
(Assignee)

Comment 26

18 years ago
On ab1, if you restart or reopen the address book, did all entries appear fine?
I haven't look at your na2, but it's possible if the file is bad.
Whiteboard: [nsbeta3-][PDTP2][rtm+] → [nsbeta3-][PDTP2][rtm+] fix in hand for UI problem

Comment 27

18 years ago
I reopened 3-4 times. Restarted 2 times. Didn't help. 

Comment 28

18 years ago
Just for more user data:
I tried migrating a 4.x profile using NT, today's branch commercial build and
was able to see my mailing lists and they did display cards in the lists, but
not all of them.  This was on older 4.x and brand new 4.x profiles.

Comment 29

18 years ago
I created a new AB (temp) in 4.x profile ab. Created in a new list in temp AB 
with 3 entries. Migrated to seamonkey. Able to see all the cards and lists. The 
list correctly shows all the 3 entries. Yay!!! (Kudos to laurel for suggesting 
this!)

But, in the PAB, both the lists show only one card. The other card is lost :(
(Assignee)

Comment 30

18 years ago
I need you both to email me the na2 files that migrated with problems.  I can't 
use the one from the bug attachment.  Thanks.  I haven't been able to reproduce 
it, this is really strange.

The good thing is I do have the fix for showing "Personal Address Book" 
instead of "abook.ldif" and the content of the address book right after 
migration.
(Assignee)

Comment 31

18 years ago
With Suresh's emailed pab.na2 and my fix for the UI,  I can reporduce it now.  
I'll look into it.

Comment 32

18 years ago
PDT agrees [rtm need info] until patch and code reviews are available.
Whiteboard: [nsbeta3-][PDTP2][rtm+] fix in hand for UI problem → [nsbeta3-][PDTP2][rtm need info] fix in hand for UI problem
(Assignee)

Comment 33

18 years ago
Created attachment 16351 [details] [diff] [review]
Patch for migrating in addrbook directory
(Assignee)

Comment 34

18 years ago
Created attachment 16353 [details] [diff] [review]
Patch for same problem in import ldif file
(Assignee)

Comment 35

18 years ago
Created attachment 16354 [details] [diff] [review]
Patch for same problem in import ldif file
(Assignee)

Comment 36

18 years ago
The fix is needed for both migrating and import ldif file.  Import ldif file 
don't have the ui problem, but have the data loss problem.  Getting the code 
review now.
Whiteboard: [nsbeta3-][PDTP2][rtm need info] fix in hand for UI problem → [nsbeta3-][PDTP2][rtm need info] fix in hand
(Assignee)

Comment 37

18 years ago
Got r=bienvenu and putterman.  Need super code review.

Comment 38

18 years ago
ok, if bienvenu says it's ok, then I'm ok with it - I can't tell much from the
diffs :)
sr=alecf
(Assignee)

Comment 39

18 years ago
Change to rtm+
Whiteboard: [nsbeta3-][PDTP2][rtm need info] fix in hand → [nsbeta3-][PDTP2][rtm+] r=bienvenu+putterman, sr=alecf

Comment 40

18 years ago
rtm++
Whiteboard: [nsbeta3-][PDTP2][rtm+] r=bienvenu+putterman, sr=alecf → [nsbeta3-][PDTP2][rtm++] r=bienvenu+putterman, sr=alecf
(Assignee)

Comment 41

18 years ago
fix checked in for branch and trunk.  

Note for QA: We don't support mailing list entry in mailing list now.  Migrating 
or import ldif file won't show the mailing list entry in the mailing list if 
it's existed in 4.x address book.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 42

18 years ago
Verified in today's branch builds on windows. Yesterday's branch builds on Mac 
and Linux. 
Keywords: vtrunk

Updated

18 years ago
QA Contact: suresh → pmock

Comment 43

18 years ago
Qa-assigned to fenella
QA Contact: pmock → fenella

Comment 44

18 years ago
Linux (2001-02-16-06 Mtrunk)
Win32 (2001-02-16-06 Mtrunk)
Mac (2001-02-16-04 Mtrunk)
This problem is fixed in the trunk build too.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.