OS/2 breaks in widget after checkin for bug753

RESOLVED FIXED

Status

()

Core
ImageLib
--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Walter Meinl, Assigned: Walter Meinl)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1.1) Gecko/20090716 Firefox/3.5.1
Build Identifier: 

The final patch for bug753 contained a substitution in nsWindow.cpp that doesn't build.
g++ -o nsWindow.o -c  -DXPCOM_TRANSLATE_NSGM_ENTRY_POINT=1 -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_COM_OBSOLETE -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DZLIB_INTERNAL -DOSTYPE=\"OS22.45\" -DOSARCH=OS2 -D_IMPL_NS_WIDGET -DUSE_OS2_TOOLKIT_HEADERS -DMOZ_APP_DISPLAYNAME=\"Minefield\" -I. -IE:/usr/src/hg/mozilla-central/widget/src/os2/../xpwidgets -IE:/usr/src/hg/mozilla-central/widget/src/os2 -IE:/usr/src/hg/mozilla-central/widget/src/os2 -I. -I../../../dist/include -I../../../dist/include/nsprpub  -IE:/mozbuild1/dist/include/nspr -IE:/mozbuild1/dist/include/nss            -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -pedantic -fno-strict-aliasing -Zomf -pipe  -DNDEBUG -DTRIMMED -O2 -IE:/mozbuild1/dist/include/cairo   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Uunix -U__unix -U__unix__ -Wp,-MD,.deps/nsWindow.pp E:/usr/src/hg/mozilla-central/widget/src/os2/nsWindow.cpp
E:/usr/src/hg/mozilla-central/widget/src/os2/nsWindow.cpp: In member function 'virtual nsresult nsWindow::SetCursor(imgIContainer*, PRUint32, PRUint32)':
E:/usr/src/hg/mozilla-central/widget/src/os2/nsWindow.cpp:1713: error: 'gfxImageFrame' was not declared in this scope
E:/usr/src/hg/mozilla-central/widget/src/os2/nsWindow.cpp:1713: error: template argument 1 is invalid


Reproducible: Always
(Assignee)

Comment 1

9 years ago
Created attachment 390098 [details] [diff] [review]
fix as suggested

Peter, this is the proper fix you suggested https://bugzilla.mozilla.org/show_bug.cgi?id=753#c90
Attachment #390098 - Flags: review?(mozilla)
(Assignee)

Updated

9 years ago
Blocks: 753
Severity: normal → major
Version: unspecified → Trunk
Not clear on how this got past me, since I remember fixing it. Sorry!

Comment 3

9 years ago
Comment on attachment 390098 [details] [diff] [review]
fix as suggested

Damn, and I thought I had verified the change in Joe's updated patch. Sorry for that.
Attachment #390098 - Flags: review?(mozilla) → review+

Comment 4

9 years ago
Pushed to trunk:
http://hg.mozilla.org/mozilla-central/rev/4f99ec4051fb
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Assignee: nobody → wuno
You need to log in before you can comment on or make changes to this bug.