Closed Bug 505912 Opened 10 years ago Closed 10 years ago

"ASSERTION: View is hidden but widget is visible!" changing visibility of flash

Categories

(Core :: Web Painting, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Assigned: roc)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(2 files)

Attached file testcase
###!!! ASSERTION: View is hidden but widget is visible!: '!visible', file /Users/jruderman/central/view/src/nsViewManager.cpp, line 746

Could this be a regression from the compositor phase 1 landing?  This changeset changed some of the code around the assertion:

changeset:  6d131711f67f
user:        Robert O'Callahan <robert@ocallahan.org>
date:        Wed Jul 22 12:45:00 2009 +1200
summary:     Bug 339548. Part 9: Create nsRootPresContext::UpdatePluginGeometry, and use it. Make nsObjectFrame manage its widget directly.
Blocks: randomstyles
Attached patch fixSplinter Review
In this case the view is hidden because we have a visiblity:hidden leaf frame, but the widget is visible because we're never hiding plugin widgets anymore.

Here we should just use the widget's visibility status to control everything. This is the future-proof solution as we rely on views less and less.
Assignee: nobody → roc
Attachment #390136 - Flags: review?(dbaron)
Attachment #390136 - Flags: review?(dbaron) → review+
http://hg.mozilla.org/mozilla-central/rev/41b7c900d87c
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Depends on: 509278
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.