Closed Bug 506011 Opened 10 years ago Closed 10 years ago

[qute] New icons for the main toolbar

Categories

(Thunderbird :: Message Reader UI, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b4

People

(Reporter: andreasn, Assigned: andreasn)

References

Details

Attachments

(2 files, 4 obsolete files)

Even though we're drastically altering the main toolbar layout for Thunderbird 3, it will still be possible to customize the toolbar with all the current icons.
We need updated icons for this.
Here are the icons!
Blocks: 480470, 488061
Duplicate of this bug: 503077
Blocks: 488060
Attachment #390236 - Flags: ui-review?(clarkbw)
Comment on attachment 390236 [details] [diff] [review]
patch with icons and changes to jar.nm

I'm not sure about the Address Book icon, the perspective makes it a little hard to understand what it is.

Do we have a reply to list icon for Vista?

Otherwise everything else looks good.  Marking minus for now.
Attachment #390236 - Flags: ui-review?(clarkbw) → ui-review-
Summary: New icons for the main toolbar → [qute] New icons for the main toolbar
Attached patch updated patch (obsolete) — Splinter Review
New patch with revisited address book and reply-to-list icon added
Attached patch xp icon changes (obsolete) — Splinter Review
As I altered the primarytoolbar css file, and the XP and Aero theme share that, here are some small changes to the current xp icons in order to not break the XP theme.
Attachment #393145 - Flags: ui-review?(clarkbw)
Attachment #393145 - Flags: review?(mkmelin+mozilla)
Attachment #393146 - Flags: ui-review?(clarkbw)
Attachment #393146 - Flags: review?(philringnalda)
Attachment #393145 - Flags: review?(mkmelin+mozilla) → review?(philringnalda)
Comment on attachment 393145 [details] [diff] [review]
updated patch

i think this looks a lot better
Attachment #393145 - Flags: ui-review?(clarkbw) → ui-review+
Could you include the archive icon too for bug 480470?
Attached patch updated patch (obsolete) — Splinter Review
included archive icon and fixed the junk icon because of Bug 508548
Attachment #393145 - Attachment is obsolete: true
Attachment #396198 - Flags: ui-review?(clarkbw)
Attachment #396198 - Flags: review?(philringnalda)
Attachment #393145 - Flags: review?(philringnalda)
Attachment #393146 - Attachment is obsolete: true
Attachment #396201 - Flags: ui-review?(clarkbw)
Attachment #396201 - Flags: review?(philringnalda)
Attachment #393146 - Flags: ui-review?(clarkbw)
Attachment #393146 - Flags: review?(philringnalda)
Attachment #396198 - Attachment is patch: true
Attachment #396198 - Attachment mime type: application/octet-stream → text/plain
Attachment #396201 - Attachment is patch: true
Attachment #396201 - Attachment mime type: application/octet-stream → text/plain
Attachment #396198 - Flags: review?(philringnalda) → review+
Attachment #396201 - Flags: review?(philringnalda) → review+
Attachment #396198 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 396198 [details] [diff] [review]
updated patch

looks good. though my dilly dallying meant that the jar.mn part of the patch doesn't apply anymore.

Just regen a new patch and put it up for checkin
Comment on attachment 396201 [details] [diff] [review]
[checked in] and updated corresponding xp patch

didn't test this but I'm sure it's good.
Attachment #396201 - Flags: ui-review?(clarkbw) → ui-review+
Bryan: This should do the trick!
Attachment #390236 - Attachment is obsolete: true
Attachment #396198 - Attachment is obsolete: true
Attachment #399432 - Flags: ui-review+
Attachment #399432 - Flags: review+
Maybe mark will let us get this in now
Keywords: checkin-needed
Comment on attachment 399432 [details] [diff] [review]
[checked in] patch with unbitrotted jar.nm

Icon tweaks I'm reasonable happy with accepting as we should pick up any major errors quickly and they aren't likely to affect users in an adverse way.

a=Standard8
Attachment #399432 - Flags: approval-thunderbird3+
Checked in: http://hg.mozilla.org/comm-central/rev/1eed6232fe8b
Status: NEW → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b4
(In reply to comment #11)
> (From update of attachment 396201 [details] [diff] [review])
> didn't test this but I'm sure it's good.

Was this ever checked in? There are reports on the MozillaZine forums that toolbar icons are mixed up on Windows XP, and the patch checked in per
comment #15 only appears to contain the aero icons.
Depends on: 515624
Attachment #399432 - Attachment description: patch with unbitrotted jar.nm → [checked in] patch with unbitrotted jar.nm
Comment on attachment 396201 [details] [diff] [review]
[checked in] and updated corresponding xp patch

Checked in: http://hg.mozilla.org/comm-central/rev/d61e4d93c778
Attachment #396201 - Attachment description: and updated corresponding xp patch → [checked in] and updated corresponding xp patch
(In reply to comment #17)
> (From update of attachment 396201 [details] [diff] [review])
> Checked in: http://hg.mozilla.org/comm-central/rev/d61e4d93c778

Phew. thanks for that Mark (I can now sleep tonight)! Sorry for being unclear that I wanted both patches to go in.
I filed Bug 516384 for some issues I noticed on Vista after these patches.
Blocks: 516610
No longer blocks: 516610
You need to log in before you can comment on or make changes to this bug.