mochitest-plain: random timeout during test_tooltip.xul

RESOLVED FIXED in mozilla1.9.3a1

Status

()

--
major
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({intermittent-failure})

Trunk
mozilla1.9.3a1
x86
All
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fixed by bug 416276] [test which aborts the suite] , URL)

We just had a random orange:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1248360005.1248367231.16630.gz
Linux mozilla-central unit test on 2009/07/23 07:40:05  

89625 INFO Running /tests/toolkit/content/tests/widgets/test_tooltip.xul...

command timed out: 300 seconds without output, killing pid 6588
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1250608265.1250613626.18193.gz
WINNT 5.2 mozilla-central unit test on 2009/08/18 08:11:05
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1250631282.1250638695.7461.gz
WINNT 5.2 try hg unit test on 2009/08/18 14:34:42

Please, fix/workaround bugs which abort the suite.
Severity: normal → major
OS: Linux → All
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1250682305.1250685947.12845.gz
OS X 10.5.2 mozilla-central unit test on 2009/08/19 04:45:05
Summary: random timeout during toolkit/content/tests/widgets/test_tooltip.xul → mochitest-plain: random timeout during test_tooltip.xul
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1250809501.1250818013.23017.gz
Linux mozilla-central unit test on 2009/08/20 16:05:01

Please!
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1250870170.1250877341.28798.gz
Linux mozilla-central unit test on 2009/08/21 08:56:10  

This is a really terrible intermittent failure, because as Serge says, it stops the rest of the tests from running. Enn: have you tried reproducing this locally?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1250881072.1250883148.31089.gz
OS X 10.5.2 mozilla-central test mochitests on 2009/08/21 11:57:52  

Given the slew of other failures following this one, I wonder if this doesn't coincide with some other failure on the machine, like extra dialogs floating around.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251082783.1251090952.15322.gz
Linux mozilla-central unit test on 2009/08/23 19:59:43
{
94764 INFO Running /tests/toolkit/content/tests/widgets/test_tooltip.xul...

command timed out: 300 seconds without output, killing pid 2554
}
Whiteboard: [orange] → [test which aborts the suite] [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251216192.1251221791.20390.gz
OS X 10.5.2 mozilla-central unit test on 2009/08/25 09:03:12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251231418.1251240040.32713.gz
Linux mozilla-central unit test on 2009/08/25 13:16:58  

94855 INFO Running /tests/toolkit/content/tests/widgets/test_tooltip.xul...

command timed out: 300 seconds without output, killing pid 11765
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251251079.1251259695.29390.gz
Linux mozilla-central unit test on 2009/08/25 18:44:39

94850 INFO Running /tests/toolkit/content/tests/widgets/test_tooltip.xul...

command timed out: 300 seconds without output, killing pid 26476

buildbot.slave.commands.TimeoutError: command timed out: 300 seconds without output, killing pid 26476

Comment 23

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251636291.1251644993.23307.gz
Linux mozilla-central unit test on 2009/08/30 05:44:51
Linux mozilla-central unit test on 2009/09/01 18:31:05
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251855065.1251862141.16036.gz
WINNT 5.2 mozilla-central unit test on 2009/09/01 22:57:58
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251871078.1251879192.3543.gz
I've disabled this test for now:
http://hg.mozilla.org/mozilla-central/rev/3c41ae627125

It's been failing intermittently a lot. Either this test is broken, or some code is broken, but with nobody looking at it having almost constant orange isn't helping us.
It is interesting that this test just started failing intermittently on the tinderboxes.

This test has always failed for me on my Fedora system on my own builds.  I need to manually move the mouse around the items that should display the tool-tips to kind of jump-start it to get past this test.
Whiteboard: [test which aborts the suite] [orange] → [test disabled on m-1.9.3+] [test which aborts the suite] [orange]

Comment 29

9 years ago
Should be fixed by 513707. Bug 416276 will reenable the test.

Comment 30

9 years ago
Linux mozilla-1.9.2 test mochitests [testfailed] Started 18:35, finished 19:18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1252850709.1252853270.26628.gz
I just hit a similar-looking timeout in test_menuchecks.xul (in the same directory as test_tooltip.xul, this bug's main test so far):
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1253209334.1253216783.2554.gz
Linux mozilla-1.9.2 unit test on 2009/09/17 10:42:14
{
89539 INFO Running /tests/toolkit/content/tests/widgets/test_menuchecks.xul...

command timed out: 300 seconds without output, killing pid 7756
}

Perhaps it's the same underlying issue as this bug...
We should disable this test on 1.9.2 like I did on trunk until we get the fix from bug 416276.
(In reply to comment #35)
> I just hit a similar-looking timeout in test_menuchecks.xul

This timeout happened again, so I'm giving it its own bug -- bug 517406.  Sorry to add spam to this bug.

Comment 40

9 years ago
Should be fixed by the patch in 416276

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Depends on: 416276
Whiteboard: [test disabled on m-1.9.3+] [test which aborts the suite] [orange] → [Fixed by bug 416276] [test which aborts the suite] [orange]
Target Milestone: --- → mozilla1.9.3a1
Not sure the cause is the same, bug 416276 has been fixed on 1.9.2 as well, but I can see the timout again:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1257972744.1257976608.4090.gz
Linux mozilla-1.9.2 test mochitests
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 43

8 years ago
waitForFocus changes should have fixed this.

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [Fixed by bug 416276] [test which aborts the suite] [orange] → [Fixed by bug 416276] [test which aborts the suite]
You need to log in before you can comment on or make changes to this bug.