If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browser.history.grouping is not supported by Places, but still in firefox.js

RESOLVED FIXED in Firefox 3.6a1

Status

()

Firefox
Bookmarks & History
--
trivial
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Greg Cook, Assigned: mkohler)

Tracking

({verified1.9.1})

unspecified
Firefox 3.6a1
verified1.9.1
Points:
---

Firefox Tracking Flags

(status1.9.1 .4-fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

This is a regression from Firefox 3.0.  

Reproducible: Always

Steps to Reproduce:
1. Enter "about:config" in the URL bar, accept warning if necessary
2. Scroll or filter to browser.history.grouping
3. Right click, select Modify, enter "none".
4. Select History -> Show All History.
Actual Results:  
Library window appears with History folder and subfolders Today, Yesterday, Last 7 days etc.  Each subfolder contains a subset of the history.

Expected Results:  
Library window should appear with History folder and all history items directly in this folder.

Workaround: type a space in the Search History textbox of the Library window.  (Probably) all history items are shown in the result list.  I think it causes a search for the empty string, which matches everywhere, but can't be sure.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090723 Minefield/3.6a1pre

Confirming the described behavior.
Places does not support that pref at all, sounds like a 2.0 pref, but it's still in firefox.js
afaict the pref should be considered deprecated, instead Today container should be selected by default (bug 82301).
confirming to remove the unused pref.

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Can't see all history, ignores browser.history.grouping = none → browser.history.grouping is not supported by Places, but still in firefox.js
(Assignee)

Updated

8 years ago
Assignee: nobody → michaelkohler
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Severity: minor → trivial
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 3

8 years ago
Created attachment 390811 [details] [diff] [review]
remove browser.history.grouping
Attachment #390811 - Flags: review?(dao)

Updated

8 years ago
Attachment #390811 - Flags: review?(dao) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
(Assignee)

Comment 4

8 years ago
Comment on attachment 390811 [details] [diff] [review]
remove browser.history.grouping

very low risk, asking for approval1.9.1.2
Attachment #390811 - Flags: approval1.9.1.2?
Comment on attachment 390811 [details] [diff] [review]
remove browser.history.grouping

Need this on trunk before we take it on branch, despite the low risk. Moving out to 1.9.1.3.
Attachment #390811 - Flags: approval1.9.1.2? → approval1.9.1.3?
http://hg.mozilla.org/mozilla-central/rev/372b31be884c
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.6a1

Comment 7

8 years ago
This is yet another case where Firefox's UI designers found a sick puppy and buried it alive rather than nursing it back to health.  This particular option is actually one of the big reasons why I stopped using IE in the first place.  If you guys keep trying to be just like every other browser, soon there won't be any reasons left for people *not* to use some other browser.

When I view my History, particularly when I click on a menu item that reads "Show All History", I expect to see *all* my history.  Furthermore, I want to see what I'm looking for *in context* of what I had been looking at before and after, so the search box is useless to me.  What I don't expect to see is a history split into arbitrary "subsets" based on what the clock happened to say at the time (as it turns out, I do a great deal of browsing around midnight), and I certainly don't expect to have to guess which of these subsets might contain what I'm looking for before being allowed to see any history at all.

What I want most is to be able to go back to my old method of searching, where I could access absolutely anything in my history by clicking in the history window *once* (on the scroll bar) and dragging.

I'm sure I already lost this argument long before I joined it, but I need to vent.  Again.
(Reporter)

Comment 8

8 years ago
Agreed.  It's infuriating as they removed a harmless, non-default option.  There used to be an add-on with this feature, "Enhanced History Manager", for those who missed the versatility of Netscape 7:

https://addons.mozilla.org/en-US/firefox/addon/420

The change of title was especially jarring, sorry if you were wondering why the description didn't match.  The original title was "Can't see all history, ignores browser.history.grouping = none" with Minor severity.  I'll include the title in all future bug summaries.
Comment on attachment 390811 [details] [diff] [review]
remove browser.history.grouping

Approved for 1.9.1.4, a=dveditz for release-drivers
Attachment #390811 - Flags: approval1.9.1.3? → approval1.9.1.4+

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/51db53a347b5
status1.9.1: --- → .4-fixed
Keywords: checkin-needed
Verified fixed in 1.9.1 with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090918 Shiretoko/3.5.4pre (.NET CLR 3.5.30729).
Keywords: verified1.9.1

Updated

8 years ago
Duplicate of this bug: 518976
You need to log in before you can comment on or make changes to this bug.