If you have more than one open window, and you close all of them, only the last window closed will be restored if you have the "Show my windows and tabs from last time" setting on.

RESOLVED INVALID

Status

()

Firefox
Session Restore
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: vincent9679, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

When you open Firefox, and you open more than one window, then close them all, only the last window that was closed will be restored when you restart Firefox.

Reproducible: Always

Steps to Reproduce:
This will only work if you have the "Show my windows and tabs from last time" setting enabled. To enable this, click Tools > Options... > In the "Main" Tab, under Startup, in the drop down box next to "When Firefox Starts:" select "Show my windows and tabs from last time".

1. Open Firefox.
2. Go to any webpage in each window.
3. Open another window (or more).
4. Close all windows.
5. Reopen Firefox.
Actual Results:  
Only the last window closed was restored, and not the other ones.

Expected Results:  
Open all the windows closed.

I don't really think it's possible to fix it, but I'm hoping. I've lost lots of useful tabs and windows by this bug.
This is a dupe of something else, but can't find it off-hand.

On the plus side, 3.5 allows you to undo closed windows and the list of those windows is maintained with session restore data. So you should be able to at least get (some of, depending on pref) those windows back.

Alternatively, you can do a full quit of Firefox by going to "File | Exit" in your menu. This will quit Firefox and when you start it again you will have all of your windows restored.
Whiteboard: [DUPEME]
I'm not sure if I'm seeing this, or another bug, but I have this pref set, and it is losing them pretty regularly when I have to restart.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

8 years ago
Can't find the dupe, either, so resolving this one as INVALID.

David: Please file a new bug on your issue (if possible with slightly more detailed StR).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Duplicate of this bug: 524366
Duplicate of this bug: 524366
You need to log in before you can comment on or make changes to this bug.