If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Button OK in Rename folder dialog doesn't work

RESOLVED DUPLICATE of bug 506004

Status

SeaMonkey
MailNews: General
RESOLVED DUPLICATE of bug 506004
8 years ago
8 years ago

People

(Reporter: rickiees, Unassigned)

Tracking

Other Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Using Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1.

Trying to rename a mail folder doesn't work as expected, depending on previous focus I think. As reported by Gianluca Turconi in m.d.a.seamonkey:

1) create a new email folder in your account;
2) right click on it and choose "rename folder..."
3) change folder name and try to close the Rename Folder dialog by pressing OK.

The dialog should close itself and the folder should change its name to the new one. However, the dialog stays open.

Most of the time, you can perform the renaming by pressing Enter instead of clicking the OK button.

After reproducing this behavior, you can get the Rename folder dialog to work properly followint these steps:

1) Click on another folder to select it.
2) Click back on the folder to rename.
3) Right-click on it and choose "Rename folder...".
4) This time you shouldn't have any problem to make the dialog work by pressing Enter and probably the OK button will work, too.

Every time the problem happens, this exception is registered in the Error Console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIRDFService.GetResource]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: SelectFolder :: line 1427"  data: no]
Flags: wanted-seamonkey2?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: wanted-seamonkey2?
Resolution: --- → DUPLICATE
Duplicate of bug: 506004
You need to log in before you can comment on or make changes to this bug.