[W-2.2.1] Recently Viewed Collections

VERIFIED FIXED in 5.0.9

Status

addons.mozilla.org Graveyard
Collections
P1
normal
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: fligtar, Assigned: jbalogh)

Tracking

unspecified
5.0.9

Details

(URL)

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

8 years ago
The collection directory sidebar should have a grid of icons or a list of names representing recently viewed collections so users can easily get back to recent collections. This is available to both logged-in and logged-out users.

Please use localStorage for this feature. (the feature will not be available to browsers that do not support localStorage or have JS disabled)

Assigning to chowse for designs.
Hi-fid mockup:
http://people.mozilla.com/~chowse/drop/collections/5.0.8/Collection_Listing_Recent_HiFid.png
(Reporter)

Comment 2

8 years ago
I like the Recently Viewed section. My concern with changing the top box is that the overall stats page isn't planned and the browse my collections link is the same as the My Collections tab. So the only helpful link there is Create a Collection, which is what's there currently.

I think we'll eventually have something to replace that box with for collection owners, but right now I don't think the replacement box provides enough value to warrant it.
I agree with Justin.  I'm not really sure why we're trying to replace browser history anyway, but that's another discussion I guess.
(Reporter)

Updated

8 years ago
Priority: -- → P1
(Reporter)

Comment 4

8 years ago
We can implement this with only the Recently Viewed portion of the mockup.
Assignee: chowse → jbalogh
(Assignee)

Comment 5

8 years ago
Can we use localStorage for this?  It's supported in FF 3.5, Safari 4, and IE8.  This is not an essential piece, so I think it's ok to not show it in older browsers.

http://www.quirksmode.org/dom/html5.html#localstorage
(Reporter)

Comment 6

8 years ago
As mentioned in the description, yes, please use localStorage.
(Assignee)

Comment 7

8 years ago
Oh right.  I usually ignore the words you write, I'll try to be better about that from now on.
I was going to give this bug to someone else but fligtar said you really wanted to use localStorage
(Assignee)

Comment 9

8 years ago
Created attachment 394380 [details] [diff] [review]
show recently viewed collections
Attachment #394380 - Flags: review?(clouserw)
(Reporter)

Comment 10

8 years ago
I tested this out on your khan and it looks pretty cool. One comment is that the Recently Viewed box should also show in the sidebar of the directory and search results, not just on collection view pages.
(Reporter)

Comment 11

8 years ago
Well, now it's not showing up at all, which leads me to believe you're messing with things! boooooo git
(Assignee)

Comment 12

8 years ago
Created attachment 394412 [details] [diff] [review]
v2

Now showing on all collection detail, listing, and search pages.
Attachment #394380 - Attachment is obsolete: true
Attachment #394412 - Flags: review?(clouserw)
Attachment #394380 - Flags: review?(clouserw)
(Assignee)

Comment 13

8 years ago
Created attachment 394414 [details] [diff] [review]
v3

With all the necessary files this time.
Attachment #394412 - Attachment is obsolete: true
Attachment #394414 - Flags: review?(clouserw)
Attachment #394412 - Flags: review?(clouserw)
Comment on attachment 394414 [details] [diff] [review]
v3

Pretty close, I'm seeing some dupes though.  To reproduce:

1) Load collection A
2) Load collection B
3) Refresh collection A (b will show up)
4) Refresh collection B (collection A will show up twice)
Attachment #394414 - Flags: review?(clouserw) → review-
Created attachment 394464 [details]
screenshot
(Assignee)

Comment 16

8 years ago
Created attachment 394526 [details] [diff] [review]
v4

Thanks for the catch.  It was broken due to a typo, but now it's way better.
Attachment #394414 - Attachment is obsolete: true
Attachment #394526 - Flags: review?(clouserw)
(Assignee)

Comment 17

8 years ago
Created attachment 394527 [details] [diff] [review]
v4, for real

Of course, it helps to check in changes before cutting a new patch.
Attachment #394526 - Attachment is obsolete: true
Attachment #394527 - Flags: review?(clouserw)
Attachment #394526 - Flags: review?(clouserw)
Comment on attachment 394527 [details] [diff] [review]
v4, for real

Works in FF.  Let's double check it doesn't break other browsers.
Attachment #394527 - Flags: review?(clouserw) → review+
(Assignee)

Comment 19

8 years ago
I played with it (successfully!) in Safari4 and IE8.
(Assignee)

Comment 20

8 years ago
r49377
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: push-needed
Resolution: --- → FIXED
Verified FIXED using Firefox 3.5.2, Namoroka, IE 8, and Safari 4.0.3 (works).

Also regression-tested using Firefox 2.0.0.20, Opera 9.64, and Google Chrome (doesn't work, but no regressions found).
Status: RESOLVED → VERIFIED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.