Presence of RSS <link> imposes a minimum width on document with loss of scrollbars

RESOLVED DUPLICATE of bug 428939

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 428939
8 years ago
8 years ago

People

(Reporter: james, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

For sites with elements set to fill 100% of their parent container's width, the presence of a <link type="application/rss+xml" rel="alternative" ... /> tag in the <head> causes those elements to get "stuck" at a width larger than the current browser window. It looks like a min-width is imposed on them.



Reproducible: Always

Steps to Reproduce:
The following code should reproduce the issue:

<html>
<head>
<link rel="alternate" type="application/rss+xml" href="/path/to/rss.xml" />
</head>
<body>
<div style="background:#FF0000;width:100%;">
<p>test contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest contenttest content</p>
</div>
</body>
</html>
Actual Results:  
If you open a page containing that code and try to narrow the browser window you'll see at some point the <p> no longer wraps, but scrollbars do not appear to allow access to the offscreen content.

Expected Results:  
If you remove the <link> element from that code and try again the <p> content wraps correctly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428939
You need to log in before you can comment on or make changes to this bug.