Uploading very large image shows blank page instead of error

RESOLVED FIXED in Q4 2010

Status

addons.mozilla.org Graveyard
Public Pages
P4
minor
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Details

(Whiteboard: [AMO508Testday], URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Builds Bug is Present On: IE7 and Fx3.5.1


Steps to Reproduce:
1. Login at addons.mozilla.org
2. Go to My Account 
3. Choose the save image (given from the URL link)
4. Click on Save

Actual Results: 
A blank page will show up. If you reload the page, a page with the link text "There are errors in this form. Please correct them and resubmit."

Expected Results:
The account page should show up again with an error.
(Reporter)

Updated

9 years ago
Whiteboard: [AMO508Testday]

Comment 1

9 years ago
Could this be a server settings problem? Maybe the max_execution_time or max_upload_size should be changed?

Comment 2

9 years ago
(^ in php.ini settings)
Created attachment 390511 [details]
Live HTTP Header output

Comment 4

9 years ago
As per IRC chat with :closerw :

<clouserw> execution time should be __30 sec__
<clouserw> upload_max_filesize should be 32M
<clouserw> post_max_size may be 16M though

Can someone with good upload link try to reproduce this one?
I have a 6mbps up connection and I get the error in comment 0, on preview.
I just uploaded a 3.2M picture to preview and it worked fine:

https://preview.addons.mozilla.org/en-US/firefox/user/10482/picture

How big are these pictures you're uploading?  Because much bigger than that and I'm leaning towards wontfix anyway.
Wil, we're using the image in the URL field: http://visibone.com/countries/countrychart_4080.jpg.
Created attachment 390766 [details]
screenshot

Ah, I see.  The image I tried had a larger file size but smaller dimensions so I don't think this has to do more with memory resizing/processing the image after it's uploaded.

For the record, the attached is what I see on my dev copy using the same memory settings as preview and production.
not a 5.0.8 bug
Severity: critical → normal
Target Milestone: 5.0.8 → ---

Comment 10

9 years ago
I have similiar problems with large images showing up blank.

If I go to
http://images.csntm.org/Manuscripts/GA_0311/GA_0311_0001.jpg
The image is fine in the 'unexpanded' mode. Mouse over and click to expand, it gives a properly sized blank. click again and the image reduces in size properly, but stays blank. <shift>-reload causes the image to reload and display correctly (but still not expand).

Save as saves the image just fine, even if the image is blank on the screen.

If I look in the cache, the cached image is correct.

I see this problem on Linux (Fedora 11, x86_64, FF 3.5.2). I don't see the problem on Windows XP (32-bit) with the same version of FF.

If this is a separate problem I'd be happy to create a new bug.

bob

Comment 11

9 years ago
Arg, never mind -- the description says blank page, not blank image. I'll look elsewhere and create a new bug if I can't find an appropriate one.

bob
Severity: normal → minor
Priority: -- → P4
Target Milestone: --- → 4.x (triaged)
We just rewrote the user profile editing and launched it in our new codebase. I tried uploading the image in the URL field above and although the blank page problem is fixed, it acts like the update was successful but the image never shows up.

If the image is too large, we should at least show an error stating the maximum size.
Component: Administration → Public Pages
QA Contact: administration → web-ui
Target Milestone: 4.x (triaged) → Q4 2010
What's the url?  It's probably just a cache issue.
Indeed, it shows up now. The cache issue is separate.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.