Closed Bug 506443 Opened 11 years ago Closed 5 years ago

[ml] XML Parsing error in netError.xhtml - line 322 column 39 protocolNotFound.longDesc

Categories

(Core :: DOM: Navigation, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 569229

People

(Reporter: amarghosh, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; ml; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; ml; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

The issue was found in the Malayalam (ml) localized version of Firefox 3.5.1
The site says its still in beta and may contain translation errors, but this doesn't seem like a translation error (seems more like lack of it).

Whenever Firefox is not able to connect to the Internet due to a network issue, instead of displaying the normal error page giving info on the error, you get a page saying there was an XML parsing error. 

The net error page (chrome://global/content/netError.xhtml) throws an xml parsing error at line 322, column 39. The relevant line is:
<div id="ed_protocolNotFound">&protocolNotFound.longDesc;</div>

Reproducible: Always

Steps to Reproduce:
1. Install the malayalam version of Firefox 3.5.1
2. Unplug the net connection (or do whatever it takes to get a "Request cannot be completed" or "Proxy Server Refused Connection" error - that loads chrome://global/content/netError.xhtml).
3. Try to access any page on the web.
Actual Results:  
XML പാഴ്സിങ് പിശക്: ശരിയായി ക്രമികരിച്ചിട്ടില്ല //(Translates to XML parsing error)

സ്ഥലം: jar:file:///C:/Program%20Files/Malayalam%20Firefox/chrome/toolkit.jar!/content/global/netError.xhtml //the page location

വരി നംബര്‍ 322, നിര 39: //line number 322, column 39

<div id="ed_protocolNotFound">&protocolNotFound.longDesc;</div> //error pointer points to the & sign.

Expected Results:  
Error message (in Malayalam) saying "Request cannot be completed" or "Proxy server refused connection", followed by the long description of error.

There is another xml entity namely protocolNotFound.title a few lines above this line in the same xhtml page. That's not throwing any error. Presumably, the malayalam translation of the long description (protocolNotFound.longDesc) about the error is not defined. If that is the case, I think it can show the default description in English itself until a translation is available. 

By the way, how can I get involved in fixing this and/or other bugs?
Moving to the Malayalam localization component.

https://wiki.mozilla.org/L10n:Home_Page is a good starting point to get involved.
Component: General → ml / Malayalam
OS: Windows Vista → All
Product: Firefox → Mozilla Localizations
QA Contact: general → ml
Hardware: x86 → All
Summary: XML Parsing error in netError.xhtml - line 322 column 39 protocolNotFound.longDesc → [ml] XML Parsing error in netError.xhtml - line 322 column 39 protocolNotFound.longDesc
Appreciate if some one could help me to understand whats the issue here :(

Thanks
Ani
This is not a Malayam-specific bug.  I just got this error several times in an en-US Aurora 26.0a2 nightly build on Windows 8 (desktop), buildID 20131004004003 built from http://hg.mozilla.org/releases/mozilla-aurora/rev/a4b7282df517

XML Parsing Error: unexpected parser state Location: jar:file:///C:/Program%20Files%20(x86)/Aurora/omni.ja!/chrome/toolkit/content/global/netError.xhtml Line Number 304, Column 68:
        <div id="ed_connectionFailure">&connectionFailure.longDesc;</div> -------------------------------------------------------------------^

This happened intermittently but frequently while using a flaky wi-fi connection at the Mozilla Summit.
Status: UNCONFIRMED → NEW
Component: ml / Malayalam → Document Navigation
Ever confirmed: true
Product: Mozilla Localizations → Core
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569229
You need to log in before you can comment on or make changes to this bug.