Segmentation fault on startup, ends in _IO_seekoff

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
critical
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Tommy.B, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (X11; I; Linux 2.2.16 i686)
BuildID:    M17, can't see build ID because it won't start up

mozilla (M17 package) crashes immediately after startup with a segfault.
I'm using Linux (SuSE 6.1) with 128MB RAM, glibc 2.1.3
Backtrace in additional information.

Reproducible: Always
Steps to Reproduce:
On my system it's enough to try to start Mozilla.

Actual Results:  							

Expected Results:  make Mozilla at least start up ;)

I updated to glibc-2.1.3 some time ago.
Every other programm or application works fine, though, C++ programs too.
Mozilla is the only exception till now.

Any ideas for what's the reason to this?

Here's a stacktrace:

tommy@tommy:~/downloads/package > ./run-mozilla.sh -g -d gdb
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.:/opt/netscape/realplayer5:/usr/local/lib
     LIBRARY_PATH=.
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=gdb
/usr/bin/gdb ./mozilla-bin -x /tmp/mozargs1738
GNU gdb 4.17.0.11 with Linux support
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(no debugging symbols found)...
(gdb) run
Starting program: /home/tommy/downloads/package/./mozilla-bin
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x401fffb0 in _IO_seekoff (fp=0x8057010, offset=0, dir=0, mode=2)
    at ioseekoff.c:42
ioseekoff.c:42: File not found.
(gdb) bt
#0  0x401fffb0 in _IO_seekoff (fp=0x8057010, offset=0, dir=0, mode=2)
    at ioseekoff.c:42
#1  0x4028f57c in fseek (fp=0x8057010, offset=0, whence=2) at fseek.c:39
#2  0x400cfb11 in bufio_Open ()
#3  0x400cae7c in nsXPTCStubBase::Sentinel9 ()
#4  0x400cc487 in nsXPTCStubBase::Sentinel9 ()
#5  0x400cc7e0 in NR_RegOpen ()
#6  0x400b364f in nsRegistry::OpenWellKnownRegistry ()
#7  0x400aca40 in nsComponentManagerImpl::PlatformInit ()
#8  0x400ac587 in nsComponentManagerImpl::Init ()
#9  0x4008051c in NS_InitXPCOM ()
#10 0x804d81e in JS_PushArguments ()
#11 0x402518c3 in __libc_start_main (main=0x804d72c <JS_PushArguments+10924>,
    argc=1, argv=0xbffff7b4, init=0x804a860 <_init>, fini=0x8051fd0 <_fini>,
    rtld_fini=0x4000be80 <_dl_fini>, stack_end=0xbffff7ac)
    at ../sysdeps/generic/libc-start.c:92

Comment 1

18 years ago
Confirming on latest Linux build.
Running glibc-2.1.3-5mdk

My console output is as follows:

./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.
     LIBRARY_PATH=.
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
RegSelf Unicode to Big5 converter complete
RegSelf Unicode to x-x-big5 converter complete
RegSelf Big5 to Unicode converter complete
*** QfaServices is being registered
RegSelf Shift_JIS to Unicode converter complete
RegSelf EUC-JP to Unicode converter complete
RegSelf ISO-2022-JP to Unicode converter complete
RegSelf Unicode to Shift_JIS converter complete
RegSelf Unicode to EUC-JP converter complete
code to ISO-2022-JP converter complete
RegSelf UniRegSelf Unicode to jis_0201 converter complete
RegSelf Unicode to jis_0208-1983 converter complete
RegSelf Unicode to jis_0212-1990 converter complete
./run-mozilla.sh: line 29: 29106 Segmentation fault      $prog ${1+"$@"}

Comment 2

18 years ago
Also observed segfault with 2000082821 but 2000082811 appears to work.

cc self

Comment 3

18 years ago
We were segfaulting at startup last night, but the change is backed out.  Blame
hyatt, and please try the latest Linux build.  Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
I just pulled the latest Nightly Build for Linux, but the segfault remains.
Your crashes seem to have an other reason than mine; all previous versions of
Mozilla, including M15, M17 and all Netscape6 Preview releases used to crash on
my system exactly the same way.
Perhaps Mozilla conflicts with my system setup?
Also no other program has problems and Mozilla crashes in a very early stage, it
doesn't print anything on the console.

Comment 5

18 years ago
I'm on Debian/Woody with glibc-2.1.3, 256Mb RAM and Linux 2.2.16. Saw this
segfault over twelve hours ago with the then latest build. Current latest
2000082908 works fine though.

Unless reporter can pinpoint this or another user can confirm with latest build,
I suggest we leave WFM.
(Reporter)

Comment 6

18 years ago
Tried 2000082908 and other builds last night, but it keeps segfaulting.
Meanwhile I tried lotta things on my system, recompiling glibc etc., but that
didn't help.
I think I'll take a closer look on the sourcecode now; stracktrace says mozilla
dies in some libc function call, perhaps bad pointer passed or something.
Question is, why does it only do that on my system?

Comment 7

18 years ago
did you delete all previous mozilla files including profile?
(Reporter)

Comment 8

18 years ago
yes, but the problem seems to be something else.
An interesting fact I found is that _all_ binary distributions I downloaded from
mozilla.org seem to crash, while all builds I did on my own system until now
seem to work.
I today tried different setups for my builds, but also non-debug and optimized
builds do run, if I build them here.
Do you use some other special build flags for the official builds?

Comment 9

17 years ago
**Mass Spam**
Adding verifyme keyword to all non-verified bugs on browser general.
Keywords: verifyme

Comment 10

17 years ago
posted using linux 2000-09-26-09-MN6 mozilla build. Redhat 6.something. I don't
have Suse - so reopen if it's still crashing on Suse.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

17 years ago
Resolved so that it works for me now.
The reason was a version problem with libstdc++.
Using objdump I found out that the binary distributions were linked against the
file libstdc++-libc6.1-1.so.2, which on my system was pointing to an older
version of libstdc++ compiled with an other version of gcc and glibc than I use
now, which probably caused the segfault.
I now made the link point to a libstdc++ that I compiled recently using
gcc-2.95.2 and glibc-2.1.3, and now it runs.
My own builds used to work because ld linked them against the newest version of
libstdc++ found on my system, which was the right one.
Confirming WORKSFORME ;)
Product: Browser → Seamonkey

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.