Won't load folders/emails in windows on dual boot (ubuntu/vista) system

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: John, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.22 (20090605)

I have a dual boot system, Ubuntu 9.04 and Vista.  I've been using Thunderbird in Vista with no problems, I recently started using my Ubuntu side more so configured my mail to work from both OS's (using Thunderbird in both OS's).  On the Ubuntu side I just used the Windows profile path (I have my Windows partition mount when I load Ubunutu).  Now, when I open Thunderbird in Vista I can't see my folders or emails, however in Ubuntu, I see them fine.  I've tried changing views thinking I inadvertently hid something, to no avail.  What's strange is that when I first tried using Thunderbird from both OS's, I booted into both and was able to see my folders/emails.  I'm not sure when it stopped working, but I can no longer view any folders or messages on the Vista side.  I'm assuming it has to do with carriage returns, or how files are saved in Linux.

As an FYI, my windows partition is NTFS.

Another FYI, it appears to have received message even though I can't few them, what I mean is, I don't see any folders or emails in Vista, yet it appears to be downloading new messages.  When I open Thunderbird in Ubuntu, my new messages are there (I disabled my network before opening Thunderbird to be sure it didn't download them at that point).

Reproducible: Always

Steps to Reproduce:
1. Install Thunderbird in Vista
2. Install Thunderbird in Ubuntu
3. Use Thunderbird in Ubuntu for a bit
4. Try viewing messages/folders in Vista
Actual Results:  
Can't see any messages or folders.

Expected Results:  
I should see my folder list on the left had side (using Classic View), and emails on the right.
Version: unspecified → 2.0

Comment 1

9 years ago
Tried "Rebuild index" in the folder properties. (If that works, this is a dupe, something about file time stamps.)
(Reporter)

Comment 2

9 years ago
FYI...I tried rebuilding the index prior to submitting the bug report, to no avail.
(In reply to comment #0)

If physically single PC, and if not tow virtual machines under VMWare etc., Thunderbird on MS Win is absolutely irrelevant to existence of dual boot Linux, although it's affected by previous use of Tb's files by Linux.

First, check at least next.
1. %APPDATA%\Thunderbird\profiles.ini (pointers to profile directory)
2. %APPDATA%\Thunderbird\Profiles\... (profile directory if IsRelative=1)
3. %APPDATA%\Thunderbird\Profiles\...\prefs.js (preference, pointers to dir/file)
4. Account definitions in prefs.js (pointer to mail directory)

If extension is used, it can't be shared with MS Win and Linux because of next.
> Bug 344671 extensions.ini should use relative paths
Does your problem occur with -safe-mode?
(Reporter)

Comment 4

9 years ago
I've check the mentioned files and nothing looks out of the ordinary (files/dir are C:\\Users\\Name....).

However -safe-mode is on to something, when run in safe mode everything comes up fine and I can check, send emails, see all my folders, etc.

I tried uninstalling all of my plugins, but that didn't help, still it does not come up correctly.  Any other ideas?  Is this a technical problem or a bug?
(Reporter)

Comment 5

9 years ago
I've fixed the issue, I renamed localstore.rdf (as suggested here:  http://kb.mozillazine.org/Standard_diagnostic_-_Thunderbird) and now everything is working fine.  I hadn't done any changes to toolbars so I'm not sure what else this file affects, but it's looking good now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 6

9 years ago
->INVALID (FIXED is only used when known code changes resolved the issue)
https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.