With "Automatically download new messages" OFF, new messages are not checked for at start up nor periodically on POP mail servers

RESOLVED DUPLICATE of bug 458625

Status

MailNews Core
Networking: POP
--
major
RESOLVED DUPLICATE of bug 458625
9 years ago
9 years ago

People

(Reporter: Arkady Sherman, Unassigned)

Tracking

({regression})

1.9.1 Branch
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

There are "Check at start up" and "Check every 2 minutes" settings checked in preferences for POP account. But Tb never reports that there are new messages automatically without the account being checked manually by pressing the "Get mail" button.

Reproducible: Always

Steps to Reproduce:
1. Create an POP account
2. Set "Check at start up" and "Check every 2 minutes" settings checked 
3. Send a letter to the account

Actual Results:  
Tb doesn't report that there are new messages

Expected Results:  
It has to report about new messages.
WFM here on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2pre) Gecko/20090725 Lightning/1.0pre Shredder/3.0b4pre ID:20090725112141
How about next setting?
> [ ? ] Automatically download new messages
New mail alert isn't possibly displayed without this setting(if so, may be regression)
Component: General → Networking: POP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.pop
Version: unspecified → 1.9.1 Branch
David any idea what we could check here ?
Are the messages downloaded and the issue is 'just' about the reporting not happening or are the messages not downloaded ?
(Reporter)

Comment 5

9 years ago
"Automatically download new messages" is off. So the issue is about reporting not
happening, although it works well with Tb 2.
Arkady could you try to see if it still happens with
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/ ?

Here with last release it seems all work fine.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2pre) Gecko/20090727 Lightning/1.0pre Shredder/3.0b4pre ID:20090727034746

Comment 7

9 years ago
I don't see a new mail indicator on startup if I turn off "automatically download new messages" . I'm not convinced we're even talking to the server, but a pop3 protocol log would confirm that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

9 years ago
> Arkady could you try to see if it still happens with
Doesn't work for me :(. Probably it's worth to note that I make use of master password.
(Reporter)

Comment 9

9 years ago
I don't need to download all messages automatically, I just want to know that a new message has been arrived to my inbox. By the way that worked fine in Tb2.

Comment 10

9 years ago
if you have a master password, we're not going to make the background check for new mail prompt you for your master password. Did we do that in TB 2?

Comment 11

9 years ago
From a pop3 protocol log, it looks like we're checking for new mail, but we're just not doing the new mail notification. This is in a profile w/o a master password. But, perhaps we prompt for the master password in your case, Arkady, on startup?
Aekady : the instrcutions to get a protocol log are written at https://wiki.mozilla.org/MailNews:Logging , if it's not clear just ask here we will help.

Comment 13

9 years ago
Arkady, is b3 the first tb 3.0 build you've tried? I tried this with b2 and it also failed to set the new mail indicator. I'm trying to get a regression window, and also be sure I'm recreating this problem correctly.
Keywords: regressionwindow-wanted
(Reporter)

Comment 14

9 years ago
I asked for master password at start up of Tb, its ok.
I tried Tb3 b2 first and this bug had been already there.
By the way I've got several IMAP and POP accounts and everything is ok with IMAPs.
Will try to log something.

Comment 15

9 years ago
no need for a log - I'm reasonably sure we're checking for new pop3 messages, just not doing the notification. The main unknown is when this broke in the 3.0 codebase.
I could reach next bug(my base of comment #2) again.  
> Bug 458625 "Check for new mail at startup" has no effect
>             without "Automatically download new messages" with pop account

Updated

9 years ago
Keywords: regression
Depends on: 458625

Comment 17

9 years ago
Bug 458625 comment 12 may know what went wrong. Probably this and bug 458625 are the same.
I understand from comment #5 and comment #7 that this bug only happens when "Automatically download new messages" is OFF, so I adjusted the summary to reflect that.
Summary: New messages are not checked for at start up nor periodically on POP mail servers → With "Automatically download new messages" OFF, new messages are not checked for at start up nor periodically on POP mail servers
(Reporter)

Comment 19

9 years ago
For me the bug happens even if "Automatically download new messages" is ON!
Closing as DUP of Bug 458625.
If this bug is for different issue, or if problem still occurs with build on which patch for Bug 458625 is already landed, please reopen.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458625
No longer depends on: 458625
(In reply to comment #19)

Mail is not downloaded even after restart of Tb? Or no biff sound?
If latter, read Bug 458625 Comment #24, please.
(Reporter)

Comment 22

9 years ago
OK, It works after Tb restarting, with "Automatically download new messages" being ON.
AFAIR, problem like next exists and old bug report for it exists.
  Change of "Automatically download ..." setting is not effective until restart.
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.