Sender with spezial characters not show

RESOLVED DUPLICATE of bug 468351

Status

--
major
RESOLVED DUPLICATE of bug 468351
9 years ago
8 years ago

People

(Reporter: uwe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; WOW64; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; SLCC1; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.5.21022; .NET CLR 3.5.30729; MS-RTC LM 8; .NET CLR 3.0.30729)
Build Identifier: Thunderbird 3.0b3

sender in inbox or other folder with spezial characters (e.g. german öäüß...) in the name not show.
Answer to this sender is not possible. (it works in TB 2.x)

Reproducible: Always
Which of next cases? Or different/new case?
> Bug 468351 display of header values with unencoded special characters broken
> Bug 493544 invalid decoding of multiline utf-8 subject header
>    (better to be tolerant with split of byte code at wrong position in RFC 2047 encoding)
(Reporter)

Comment 2

9 years ago
Created attachment 390793 [details]
Header is ok. Display broken
(Reporter)

Comment 3

9 years ago
I think it is a new problem.
This looks like bug 415368
(In reply to comment #2)
> Header is ok. Display broken

Header is never OK. Raw binary of non 7bits-us-ascii character is placed in From: header without encoding.
Because Content-Type: header is not provided by bug opener, it's impossible to know whether DUP of Bug 468351 or not from provided mail data. However, because bug opener says "it works in TB 2.x", I think DUP of Bug 468351. Closing as DUP of Bug 468351.
Re-open please, if it'll be found DUPing is wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 468351
You need to log in before you can comment on or make changes to this bug.