ajax stopped working on a users pc

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: chris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

the URL brings up a graphic, which changes in 5 seconds to a array of 30 "boxes". Box 1 is only used (in green with a number)

I wrote the page, and it has been working on many peoples PC's. However, one user had been using it for weeks and updated FF about a week ago and he could no longer get the page to work. However, he can access it with IE8 and other browsers. 

I have spent ages trying to work it out and I am out of ideas. He is using Vista with the latest FF build. We tried removing FF and putting a previous version on, no luck. We tried in safe mode and resetting FF settings to default, no luck. We tried putting the site in all the exceptions in FF, still no luck. We allowed FF access to all ports in the windows firewall, still no luck. 

Yesterday, I deleted all of FF, extentions, manually removed all mozilla folders, even went though the registery and deleted every mozilla setting I could find. Rebooted, reinstalled FF, still no luck. 

We also tried reinstalling JavaScript and many other things, and it just refuses to work on his pc. I tried a test page for ajax in FF on his pc and that worked, though I don't see any real difference in the code to mine.

FF just has "waiting" in the status message, as if its simply waiting for the data to come from my server, but FF does not ever seem to get the data and just sits "waiting" for it and thats as far as it gets. 

As he can get the site in IE8/Google Chrome/Safari , then we know its limited to FF somehow. Though I am out of ideas. As said before, he was working fine for months until he updated FF, and "something" has happend which has prevented FF and AJAX working correctly. Though I really don't know what to try next. 

my page is 

http://rooms.mymobroom.com/attackboard/fwvj84espg28urkekwzcm-index.htm

the blue banner will change to "30 boxes" in 5 seconds.. but for this one user it never does.

the test site i spoke of is
http://www.access-matters.com/2007/01/22/simple-ajax-test-1/

just click a link  and it says "hello world" so AJAX seems to work fine there in FF.

I can only assume for some reason that is a issue with vista and my site in FF. Though as he had it working for months until he updated FF, it sounds like a FF issue. Though as the test site works, then it suggests its my site. Though as he had it working in other browsers, it suggests its a FF issue. 

As such I have no idea what to try next. Its a problem to try and track down what the problem is as what works and does not work does not make sense.

I hope you can help as if it was related to him updating FF then other users of my site are going to run into the same issues soon too.

Regards, 
Chris


Reproducible: Always

Steps to Reproduce:
1.visit the URL
2.page changes from the big blue banner graphic to "30 boxes"
3.
Actual Results:  
Boxes never come up on a particular users PC running vista.
This is not a support form. You will have better luck with somewhere like http://forums.mozillazine.org/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
I did, they said its not ran by any tech people from mozilla and told said to try here as it was some bug rather than a programming related issue. oh well.

Comment 3

9 years ago
works for me, I can see the 30 boxes
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
(Reporter)

Comment 4

9 years ago
Yes it works for *some* people but not all. hence the post as to why some people using FF cannot see it. Is there any actual tech support people from mozilla anywhere ?
You need to log in before you can comment on or make changes to this bug.