Click image resizing for nsImageDocument should be disabled

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: vingtetun, Assigned: vingtetun)

Tracking

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 390804 [details] [diff] [review]
cpp Part v0.1

Steps to reproduce:
 1. Go to the test url
 2. Pan a little bit and release the mouse/finger

Actual Result:
 The image is resized

Expected result:
 The image is not resized
I think we should be looking at the InputHandler code, as well, to see if we are the ones sending the "click" at the end of the pan.
OK, to clarify -- because we have our own zoom mechanism, we want to use that instead of the desktop "click-zoom" for loading single pictures.  This should be fixed by avoiding sending click events to ImageDocuments.
Vivien, can you modify the CPP patch to only read the pref during the Init() call matching the current _PREF read and storing that in a local member?  That's the only change I think it needs before pushing for core code review.
Created attachment 391080 [details] [diff] [review]
cpp part V0.1.1

Done.
Attachment #390804 - Attachment is obsolete: true
Comment on attachment 391080 [details] [diff] [review]
cpp part V0.1.1

Boris, can you review the platform part of this patch? In Fennec we don't want to have any of the image click behavior or image scaling behavior.
Attachment #391080 - Flags: review?(bzbarsky)
Attachment #391080 - Flags: review?(bzbarsky) → review+
m-c: https://hg.mozilla.org/mozilla-central/rev/77087580d570
m-b: https://hg.mozilla.org/mobile-browser/rev/74b006ed4d76
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified fixed in the Maemo build form 8/11/2009.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.