Firefox's Save As dialog does provide option to view image

RESOLVED DUPLICATE of bug 185618

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 185618
9 years ago
6 years ago

People

(Reporter: SineSwiper, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

When the link to the image is clicked, a Save As dialog appears.  I believe this is because of the Content-Disposition header.  However, the only valid option that would work is Save, since the Use With option does not give you the chance to tell Firefox to use ITSELF to view the image.  

Image URL: http://eclipse.open.collab.net/ds/getDSMessageAttachment.do/merge_error_mixed_revision.png?dsForumId=62&dsMessageId=319230&dsAttachmentId=351303&dsAttachmentMime=image/png

The link to that image is found here:

http://eclipse.open.collab.net/ds/viewMessage.do?dsForumId=62&dsMessageId=319230

The headers are:

HTTP/1.1 200 OK
Date: Mon, 27 Jul 2009 20:14:37 GMT
Server: Apache
Set-Cookie: JSESSIONID=C7E19E4CB53A5D719752028E17AC2129; Path=/ds
Set-Cookie: JSESSIONID=C7E19E4CB53A5D719752028E17AC2129; Domain=.collab.net; Path=/
X-Powered-By: Servlet 2.4; JBoss-4.0.4.GA (build: CVSTag=JBoss_4_0_4_GA date=200605151000)/Tomcat-5.5
Cache-Control: public
Pragma: public
Content-Disposition: attachment; filename="=?UTF-8?B?bWVyZ2VfZXJyb3JfbWl4ZWRfcmV2aXNpb24ucG5n?="
Connection: close
Content-Type: image/png

Reproducible: Always

Steps to Reproduce:
1. Go to http://eclipse.open.collab.net/ds/viewMessage.do?dsForumId=62&dsMessageId=319230
2. Click on second PNG image attachment link

Actual Results:  
Save As dialog has no way to view image

Expected Results:  
There should be a third option here to allow Firefox to view the image, or the first option should be changed to allow Firefox to view the image.

Comment 1

9 years ago
Does the dialog have a Browse or Other option that allows you to choose Firefox?

Comment 2

9 years ago
One can select Other from the drop down, then go browse, then find the Firefox executable, then Firefox downloads the file to %TEMP% and opens it.

Not a great, fast or discoverable experience I have to say.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-AU; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729) ID:20090729225027

Updated

7 years ago
Version: unspecified → 3.5 Branch

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 185618
You need to log in before you can comment on or make changes to this bug.