If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TM: firefox crash [@js_GetOpcode]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: James, Unassigned)

Tracking

({crash, crashreportid})

1.9.1 Branch
crash, crashreportid
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1) Gecko/20090716 Ubuntu/9.10 (karmic) Shiretoko/3.5.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1) Gecko/20090716 Ubuntu/9.10 (karmic) Shiretoko/3.5.1

firefox crashes. I have the core file.
I do not know how it was caused.
I will attach debug output from the core file.


Reproducible: Sometimes
(Reporter)

Comment 1

8 years ago
Created attachment 390893 [details]
Output from gdb core.

Output from gdb of the core dump.
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Summary: firefox crash → TM: firefox crash [@js_GetOpcode]
Version: unspecified → 1.9.1 Branch
Nothing in crash-stats afaict. Testcase or str would really help.
Severity: normal → critical
Keywords: crash, testcase-wanted
(Reporter)

Comment 3

8 years ago
I am not prepared to upload the core file.
Is there any way to give you more information that might be useful.
It only crashes sometimes, so I cannot narrow it down to a particular test case.
What is "str" ?
What is "crash-stats" ?

As an extra, but maybe not linked, within seconds of this crash, Xorg also crashed.
Unfortunately, I did not get a core from X. I only got a core from firefox.

Comment 4

8 years ago
it could be an out of memory crash...

str = steps to reproduce
crash-stats = a server that records crash reports and enables us to look for similar reports
http://crash-stats.mozilla.com/report/index/10499b4d-5910-4d29-988d-9ab7b2090805
http://crash-stats.mozilla.com/report/index/e9846162-3f0b-45b3-90ff-19d872090807

Of the 2, the first seems to be a very similar crash as the one in this bug. Marking new.

Both other crashes were on Windows - Platform -> All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crashreportid
OS: Linux → All
Hardware: x86 → All
Crash Signature: [@js_GetOpcode]
No crashes at least within the last 4 weeks. Assuming this was fixed somewhere along the way in the last 2 years.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.