alt-based keyboard accelerators gone?

VERIFIED INVALID

Status

()

P3
minor
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: jblosser-moz, Assigned: don)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-15mdk i686; en-US; m18) Gecko/20000825
BuildID:    2000082708

Sometime in the last few days, the nightlies have changed from having the
"normal" alt-based keyboard accelerators in Linux to using ctrl-based ones.
Since most other apps in Linux use alt, this is at least annoying.  Since I have
to retrain my fingers, it's worse than annoying.

It would be nice if this was configureable, if it isn't already.  If it is
already, it would be nice if the default remained what it has been for years.  I
could do without the alt key making menus drop down.

Reproducible: Always
Steps to Reproduce:
Use any keyboard shortcuts.

Actual Results:

Expected Results:

Comment 1

18 years ago
The decision was made to use ctrl as the default accel to be more consistent
with GNOME applications.  I did not make that decision :)  You can configure it
to be alt by editing prefs.js.  Marking INVALID since the reported behavior is
the intended behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
vrfy. btw, here's what you can change to your prefs.js (or user.js) to get back
use of Alt for your accelerator key:

user_pref("ui.key.acceleratorKey", 18);

18 is for the Alt key. by default it's 17, the Ctrl key.

because of this, you should also change this other pref:

user_pref("ui.key.menuAccessKey", 0);

0 turns off the menu access keys; by default it's 18, the Alt key.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

18 years ago
Thanks.  This works.  I won't comment on the GNOME thing. :P

As long as I can change it this way I won't complain _too_ much.
(Reporter)

Comment 4

18 years ago
The method given below by S.E.V. Liberman doesn't seem to work any more in
current nightlies.  Using 2000091312, with the following in prefs.js:

user_pref("ui.key.acceleratorKey", 18);
user_pref("ui.key.menuAccessKey", 17);

If I do eg alt-f, I get nothing. If I do ctrl-f, I get *both* the find dialogue
pop up and the file menu drop down.
jblosser, use ui.key.accelKey, instead of ui.key.acceleratorKey --i found out
that was a recent change!
You need to log in before you can comment on or make changes to this bug.