Filter list disappears after New, Edit or Delete. OK next launch.

VERIFIED WORKSFORME

Status

P2
major
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: laurel, Assigned: alecf)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
Using aug29 commercial build

Here's the filter ui regression du jour. 

When any edit (New, Edit, Delete) takes place in the filter ui, the filter list
is blanked out. Upon next launch of the filter dialog the list appears and
reflects the previous edits. 

1.  From the mail window, launch a profile which has existing filters.
2.  Edit|Message Filters.  Note the existing filters are present in the list.
3.  Click New, add a new filter, OK the filter rules dialog.
    Result:  back at the main filters dialog, the list of filters is now shown
as an empty list. 
4.  OK the main filter dialog, then access filters again.
    Now the list displays showing the previously existing filters and the newly
added filter.

Scenario #2:  Edit an existing filter, OK the filter rules dialog. List in main
dialog disappears until you launch filter ui again.

Scenario #3:  Delete an existing filter, OK the confirmation dialog.  List
disappears until you launch filter ui again.
(Reporter)

Updated

18 years ago
Keywords: nsbeta3
QA Contact: lchiang → laurel
(Reporter)

Comment 1

18 years ago
There are several places in today's builds where refreshing a display doesn't
work until you force another refresh (resize, etc.). 

This filter problem actually will correct if you resize the dialog (didn't catch
that originally).

Anyway, see bug 50691 for main thread pane display problem...probably same
cause.

Comment 2

18 years ago
+, P2 per mail triage
Priority: P3 → P2
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18
(Reporter)

Comment 3

18 years ago
This is gone with today's commercial build.
OK using aug30 commercial build, linux, mac and NT.

Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
Marking verified (worksforme).
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.