GMAIL extremely slow under firefox 3.5.1 (Skype)

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: fabien.fivaz, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

Since I updated Firefox to version 3.5.1, gmail is extremely slow and finaly stops loading after a few clicks. It does not happen in IExplore or Safari...

Reproducible: Always

Steps to Reproduce:
1. load gmail
2. open spam folder (for instance)
Actual Results:  
Gmail freezes and has to be reloaded. Firefox is ok.

Expected Results:  
normal...
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2pre) Gecko/20090725 Shiretoko/3.5.2pre

No problem here. Maybe caused by an extension? Please try safe-mode: http://support.mozilla.com/en-US/kb/Safe+Mode
Version: unspecified → 3.5 Branch

Comment 2

10 years ago
Here is a link: http://rk.onet.net/slowtest2b.html which demonstrates slowness that seems to depend on the number of checkboxes on a page, even with safe mode on. The page consists of a table with 415 rows of which 414 have a checkbox. On my XP, re-loading the file or clicking a checkbox quite reliably induces an approximate 4 second delay followed by a 6 second period of 97% CPU usage. During the six seconds, FF is unresponsive. 

The same table without the checkboxes does not show the lag. The problem showed up with FF 3.5. Running on XP SP3 on Pentium4 2.00GHz, 1.25GB RAM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Reporter

Comment 3

10 years ago
I tried in Safe Mode and... Gmail worked normaly this time. But still, I don't really want to have my browser to be in safe mode all the time. I tried to deactivate all plugins and clear the cache in the "non-safe" version, and I still have the problem with gmail...

I tried the page Richard gave in the second comment. Here on my system it loads in less than a second, without any problem on my "non-safe" firefox (and in every other rowser I have).

(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2pre) Gecko/20090725
> Shiretoko/3.5.2pre
> 
> No problem here. Maybe caused by an extension? Please try safe-mode:
> http://support.mozilla.com/en-US/kb/Safe+Mode
Richard, your case is most likely Bug 477564.
Fabien, if it works in safe-mode the problem is most likely caused by an add-on. You can troubleshoot by disabling them one by one.
Also you installation folder can contain incompatible stuff that runs when Firefox runs. Deleting Firefox and reinstalling the program should solve the problem in that case.

Comment 5

10 years ago
You are absolutely right, Ria - thanks for the info.

Richard
Reporter

Comment 6

10 years ago
Well, I uninstalled Firefox and resinstalled it. Now, interestingly, Firefox doesn't even open the gmail page! And if I try to open gmail, close firefox and rerun it : it sucks all my CPU (or at least one of them) and never opens again. I have to kill firefox and then rerun it... Strange !

So I tried what you said, disabling plugins and extensions one by one. 

AND THE WINNER IS "Skype Extensions for Firefox" version 3.3.0.3739...

Maybe this "bug" (it surely comes from Skype and not Firefox itself) has already been reported ?
The version of Skype extension used in this bug has been blocklisted (see bug 448768, which blocked 3.3.0.3970 and earlier).

Can you confirm the problem no longer occurs when using newer versions of the Skype extension?
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Summary: GMAIL extremely slow under firefox 3.5.1 → GMAIL extremely slow under firefox 3.5.1 (Skype)
The reporter hasn't commented since 2009 and the version affected was blocklisted; going to close this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.