parameter for sendmail deferred mode

VERIFIED FIXED in Bugzilla 2.12

Status

()

P3
normal
VERIFIED FIXED
18 years ago
6 years ago

People

(Reporter: Chris.Yeh, Assigned: Chris.Yeh)

Tracking

unspecified
Bugzilla 2.12
All
Windows NT

Details

(Assignee)

Description

18 years ago
i get tired of having to move processmail out of the way everytime i want to 
check in a change. there should be a parameter for the sendmail deferred mode so 
that it can be easily toggled on or off without having to touch and modify local 
copies of processmail.
(Assignee)

Comment 1

18 years ago
checked in enhancement, there is now a sendmailnow parameter which toggles 
whether we send in deferred mode or not. default is OFF (send in deferred mode)

Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
This patch doesn't work in perl 5.6.  It now queues everything, regardless of 
the param.  For some reason having the 'my' in front of the $sendmailparam 
inside the if() block makes it fail to assign, since you already declared it as 
a 'my' var two lines above.

I just checked in a patch to it.  Removing the 'my' from in front of the 
variables inside the if() blocks fixed it.
*** Bug 50425 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

18 years ago
The problem has to do with Perl scoping...the my keyword in the if statement 
effectively makes it a seperate instance of that variable, so it never gets set 
to null since it gets the original value back when it leaves the if statement.

I tested this as best as I could, that's what I get for testing a single bug on 
a fast unloaded machine. (It looked like an immediate send, honestly it did!)

Thanks for the catch and the fix.
In search of accurate queries....  (sorry for the spam)
Target Milestone: --- → Bugzilla 2.12
Verified, see also bug #50159.
Status: RESOLVED → VERIFIED
Moving closed bugs to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.