Quickopen breaks during project selection

RESOLVED FIXED in 0.4

Status

Skywriter
Search
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Kevin Dangoor, Unassigned)

Tracking

Trunk
Other
Other

Details

(Reporter)

Description

9 years ago
I tried to switch to a different project with Quickopen and got the error 
"files is undefined" on line 213 of quickopen.js

for (var x = 0; x < files.length; x++) {

Comment 1

9 years ago
I can't reproduce the bug, but this bugfix should be all fine:

http://bitbucket.org/j4c/bespin/changeset/a0c6c954bbf0/
(Reporter)

Comment 2

9 years ago
The problem turned out to be a general issue with quickopen not handling the 
current state of the server -- namely, open sessions are no longer reported 
back (because we've eliminated the notion of "open sessions").

I have removed the open sessions related code from quickopen and all seems fine 
on tip again.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.4.0
I'm pretty sure Quickopen bugs belong under Search.
Component: User Interface → Search
QA Contact: user.interface → search
You need to log in before you can comment on or make changes to this bug.