Upgrade for SM 2.0b lost password

RESOLVED DUPLICATE of bug 482443

Status

SeaMonkey
Passwords & Permissions
RESOLVED DUPLICATE of bug 482443
8 years ago
7 years ago

People

(Reporter: Boris 'pi' Piwinger, Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows Vista
dataloss
Bug Flags:
blocking-seamonkey2.0b2 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
I upgraded using the automatic process from 2.0a to Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1. Before that I had my account number stored in password manager for https://www.cortalconsors.de/euroWebDe/-, since I have made the upgrade it is lost (it got actually deleted!) and is not saved anymore, when I log in again.

pi
Flags: blocking-seamonkey2.0b2?

Comment 1

8 years ago
Is this some additional info to a "username"+password that was stored in the old password manager? Or does the form state that we aren't allowed to autocomplete/save the fields? If so, this is not something that will likely be fixed and is not blocking, but there are probably other bugs on file that this should be duped to.
If this is a normal username+password entry form and the site doesn't state that we aren't allowed to autocomplete/save it, then we should look into that.
Whiteboard: DUPEME
See Bug 486829 Comment 3? Dupe of that one (that is your bug btw ;)?
(Reporter)

Comment 3

8 years ago
I am not aware of any additonal information. Since the entry was deleted (!) I cannot give you any detail. It and stopped suddenly with the upgrade.

I don't think it is a dupe since it did work with the alpha version. I cannot recall what happend to make bug 48629 work again, but it did. Easybank still works.

pi

Comment 4

8 years ago
Did you happen to back up your profile prior to upgrading to 2.0b1? If so could go back to alpha and try the upgrade again and see if it loses the password again. If it does then we can assume it is reproducible and then see if we can find a regression window, if does not then we may have trouble resolving the issue.
(Reporter)

Comment 5

8 years ago
I do have the password file from 1.x still. I might find somewhere an old copy of the whole old profile. I don't have the file from alpha anymore.

pi
(In reply to comment #3)
> I cannot recall what happened to make bug 486829 work again, but it did.

Looking for "autocompleteoverride" workaround? See bug 425145...
Severity: normal → critical

Comment 7

8 years ago
As long as we don't have clear steps to reproduce, we can't even consider this for blocking a release.
Flags: blocking-seamonkey2.0b2? → blocking-seamonkey2.0b2-
(Reporter)

Comment 8

8 years ago
Well, at least the password is not stored. This you can try.

From looking at bug 425145 I don't understand the workaround.

pi
(In reply to comment #8)
> Well, at least the password is not stored. This you can try.

Not saving/storing the password is bug 486829: don't mix issues.

(Here, we need you/someone to reproduce/confirm.)

> From looking at bug 425145 I don't understand the workaround.

It's simply a bookmark(s) to add to your profile then use...
(Reporter)

Comment 10

8 years ago
Thanks, that works nicely.

pi

Comment 11

7 years ago
I suspect that's another case of the import code from an older format to the sqlite format having issues, so it's a dupe of bug 482443.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 482443

Updated

7 years ago
Severity: critical → normal

Updated

7 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.