Closed Bug 507149 Opened 11 years ago Closed 10 years ago

js_InitJIT doesn't handle failure from JS_DHashTableInit

Categories

(Core :: JavaScript Engine, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 515812

People

(Reporter: timeless, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: coverity, crash)

6146 js_InitJIT(JSTraceMonitor *tm)
6193     if (!tm->recordAttempts.ops) {
6194         JS_DHashTableInit(&tm->recordAttempts, JS_DHashGetStubOps(),
6195                           NULL, sizeof(PCHashEntry),
6196                           JS_DHASH_DEFAULT_CAPACITY(PC_HASH_COUNT));
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 515812
You need to log in before you can comment on or make changes to this bug.