both Firefox 3 and Firefox 3.5 do not navigate back on a bookmark link placed in a division that had been set overflow: scroll (-y or auto) and has a fixed positioning

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: u353327, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

both Firefox 3 and Firefox 3.5 do not navigate back on a bookmark link placed in a division that had been set overflow: scroll (-y or auto) and has a fixed positioning

Reproducible: Always

Steps to Reproduce:
1. Pls.try the attached HTML test case
2. Navigate on the  bookmark link placed into a fixed positioned div which has an overflow-y: scroll (Css attr), then press the browser GO BACK
3. 
Actual Results:  
It won't  position back to that document point where from the jump occurred.
---------------------------------------------------------------------------------------------
Unfortunately, the GO Back from a bookmark link placed in either of similar design which has absolute or fixed positioned divisions set to overflow: auto or scroll won"t work. Listen to the bottom: 0 (Css attr) will affect hiding the body scrollbar if the BODY height: 100% set, even when the body overflow: hidden doesn't set.

Expected Results:  
Such kind of design is very useful, because doesn't require the content to be loaded into an iframe in which the bookmark links Go back also circumstantially work. 

I expect the GO BACK to work correctly in such a design under Firefox also, since it works well in IE7.

The HTML code of a sample page has been attached. Pls. try it. 
-------------
My build ID
Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 - Build ID: 20090715094852
(Reporter)

Comment 1

9 years ago
Created attachment 391380 [details]
testcase_for_bookmark_goback_error_in_iframe_type_doc_design
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
(Reporter)

Comment 3

7 years ago
I've not tested yet on Firefox 3.6.13. I'm using yet Firefox 3.5.16 because having some extensions running only on that version. The test case presented here doesn't run on 3.5.16 either and probably won't.(I've tested again now).
I'll try on Firefox 3.6.x later as mentioned. The issue surely had resolved, so I close it as asked.
Thanks for dealing with it.
iplnts(In reply to comment #2)
> Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe
> mode or a fresh profile? If not, please close. These links can help you in your
> testing.
> http://support.mozilla.com/kb/Safe+Mode
> http://support.mozilla.com/kb/Managing+profiles

(In reply to comment #2)
> Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe
> mode or a fresh profile? If not, please close. These links can help you in your
> testing.
> http://support.mozilla.com/kb/Safe+Mode
> http://support.mozilla.com/kb/Managing+profiles
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.