memory profiler reports marks instead of markIncrements

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: treilly, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
GCPolicyManager marks should probably be called objectsMarked.   Actually talking to Ruchi we decided scan would be better than mark in a lot of places we use mark.

Comment 1

9 years ago
???

GCPolicyManager already has these methods:

 objectsMarked()
 bytesMarked()

There is also an exposed member called countIncrementalMark that is the number of mark increments.  (You can argue that the mix of methods and exposed members is not good programming; we could clean this up if we care.)

Mark is used everywhere and means "mark the object and scan it for pointers to other objects" so don't change it just because you want to change it... what's the motivation for changing terminology?

Comment 2

9 years ago
The problem is in the naming of marks() in GC.h which calls objectsMarked(). GC Memory profiler calls marks to print mark increments which prints a huge value (obviously the number of objects marked) and the information is dubious in the memory profiler output. Instead of marks(), markincrements() should be called in the "mark increments" log for profiler.
(Reporter)

Comment 3

9 years ago
Fixed in http://hg.mozilla.org/tamarin-redux/rev/2deafceef097
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.