GCPolicyManager marks should probably be called objectsMarked. Actually talking to Ruchi we decided scan would be better than mark in a lot of places we use mark.
??? GCPolicyManager already has these methods: objectsMarked() bytesMarked() There is also an exposed member called countIncrementalMark that is the number of mark increments. (You can argue that the mix of methods and exposed members is not good programming; we could clean this up if we care.) Mark is used everywhere and means "mark the object and scan it for pointers to other objects" so don't change it just because you want to change it... what's the motivation for changing terminology?
The problem is in the naming of marks() in GC.h which calls objectsMarked(). GC Memory profiler calls marks to print mark increments which prints a huge value (obviously the number of objects marked) and the information is dubious in the memory profiler output. Instead of marks(), markincrements() should be called in the "mark increments" log for profiler.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.