Add capability to interact with Safebrowsing test server

RESOLVED DUPLICATE of bug 502932

Status

()

RESOLVED DUPLICATE of bug 502932
10 years ago
5 years ago

People

(Reporter: gcasto, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I think that this should mostly involve talking to a different server (localhost, port 40101 at the moment) and appending a step parameter to every request to the server (i.e. ?test_step=1).  The step would start at 1 and be incremented after you finish parsing every downloads request.  I should probably be one of the reviewers of the patch.
Probably best if we made a private interface for this that had a method looking something like this (feedback wanted):
void useTestServer(nsIURI aBaseURI);

David - would you have time to work on this?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 502932
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.