Add-On Collector: Line breaks / paragraph breaks render incorrectly

RESOLVED FIXED in BW-1.0.4

Status

RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: wis.master, Assigned: mackers)

Tracking

unspecified
BW-1.0.4

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

Line breaks / paragraph breaks in the comment/description don't render properly in the subscription window. 

Workaround: At least change a line break into a space if it has technical difficulty to display line breaks there. 

Reproducible: Always

Updated

10 years ago
Assignee: nobody → brian
(Assignee)

Comment 1

10 years ago
The API doesn't seem to preserve line breaks in the comments of the publish to collection call.

Instead, I'm adding a space after the line break so that when they are stripped, at least there is some whitespace between lines.

r48238
(Assignee)

Comment 2

10 years ago
Er, r48249
-> fligtar for comment.
Assignee: brian → fligtar
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → BW-1.0.4

Comment 4

10 years ago
Bug 498078. Line breaks need preservation on the AMO page too. Please forward dupe it here if desired.
OS: Windows XP → All
Hardware: x86 → All
I'm fine with breaks being converted to spaces in the extension since there's not much room there to work with. We'll make the other bug exclusively about the website.
Assignee: fligtar → dave
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Component: Collections → Collector Extension
QA Contact: collections → collector-extension
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.