Closed Bug 507340 Opened 11 years ago Closed 9 years ago

Statistics summary should have more information on review queue

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED
5.12.2

People

(Reporter: u278084, Assigned: kumar)

References

()

Details

Attachments

(1 file)

I think it will be worth it to have a link to the statistics summary (see URL) when an developer submits or updates their add-on. This would provide a general overview of the current state of the queue, to help give a realistic view of when an add-on might be reviewed.

I'm worried about giving concrete numbers, because it might increase the number of messages on the amo-editor mailing list. But I think it would help to give stats like :

What is the average time in the queue?
What is the median time in the queue? (how long has the add-on in the middle of the queue been waiting)
How long has the oldest extension been in the queue? (A worst case scenario).
(More?..)

We also have the data to show editor activity vs. new add-ons submitted over a week. Brownie points for showing it in a pretty bar graph.
If I am not mistaken, this is discussed in bug 483835.  For example:
(From bug 483835 comment #9)
> 2) As a developer, I still have a lot of questions.  What I most want to know
> is how long will my add-on be in the queue.  Since we can't say specifically
> maybe saying "300 add-ons in the queue, the oldest of which is _____ weeks." 
> That probably won't help though since a few are pretty old....

I have not read the discussion in 483835 carefully, and I may be wrong.  Please reopen if I am wrong.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483835
It sorta does but mostly does not. It does not give any real hits to how long the review is going to take, and that's the area I am trying to focus on. My summary title was a little broad, so I made it more specific.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Statistics summary should have more information → Statistics summary should have more information on review queue
I believe this is a duplicate of 472786.
Not a dupe, but related to bug 342931.
Priority: -- → P3
Target Milestone: --- → 4.x (triaged)
We could link to the weekly queue reports in the AMO forum: https://forums.addons.mozilla.org/viewforum.php?f=21&sid=1f3687903dd6df9cd4f676514a43cb2c

They don't include the specific stats mentioned in comment #0, but they do give a better picture of the expectations an author should have about waiting times and editor activity.

What do you think, Cesar?
Assignee: nobody → fligtar
Target Milestone: 4.x (triaged) → 5.12.3
Kumar, let's add an additional item to the submission Finished page under Next Steps:

* View approximate review queue <a href="https://forums.addons.mozilla.org/viewforum.php?f=21">wait times</a>.
Assignee: fligtar → kumar.mcmillan
Status: REOPENED → NEW
Target Milestone: 5.12.3 → 5.12.2
sure, fixed in http://github.com/jbalogh/zamboni/commit/30fa28ca513916222efdf40be819b976e55d472d

This will show up soon at https://preview.addons.mozilla.org/z/en-US/developers/addon/9660/submit-finished
Status: NEW → RESOLVED
Closed: 11 years ago9 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.