Undetermined text while loading iGoogle for the first time repeats after the page is loaded.

VERIFIED WONTFIX

Status

()

Firefox
General
VERIFIED WONTFIX
9 years ago
7 years ago

People

(Reporter: Yusuke Yamasaki, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25], URL)

Attachments

(1 attachment)

568.91 KB, application/x-shockwave-flash
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

Undetermined text (with dotted-underline using IME) typed while loading iGoogle for the first time is cut when iGoogle is loaded completely. And typing any key after that causes the text disappeard pasted again and again.

Reproducible: Always

Steps to Reproduce:
1. Start firefox.
2. Enable IME.
3. Go to iGoogle.
4. Type some characters (with dotted-underline using IME) while iGoogle is executing background ajax process.
5. When iGoogle loaded, text input at 4. disappears.
6. Type any key or click somewhere in the textbox.
7. The text disappeared at 5. is appended to the tail of textbox as many times as you type keys.
Actual Results:  
IME ON -> start firefox -> half loading iGoogle...
-> type a -> "あ" shows on search box
-> iGoogle load complete -> "あ" disappears
-> type a -> "ああ" shows on search box
-> type a -> "あああああ" shows on search box
-> mouse click on search box -> "ああああああ" shows on search box

Expected Results:  
IME ON -> start firefox -> half loading iGoogle...
-> type a -> "あ" shows on search box
-> iGoogle load complete -> "あ" remains in the search box with dotted-underline
-> type a -> "ああ" shows on search box
-> type a -> "あああ" shows on search box
-> mouse click on search box -> nothing happens

1. IME is enabled.
2. browser.startup.homepage = http://www.google.com/ig
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Updated

9 years ago
Summary: While loading iGoogle for the first time, any key input hehaves like (Ctrl+A, Ctrl+X) Ctrl+V, Ctrl+V..... → Undetermined text while loading iGoogle for the first time repeats after the page is loaded.
(Reporter)

Comment 1

9 years ago
Created attachment 391853 [details]
SWF screencast.

This screencast shows how to reproduce the bug.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
This bug has had the CLOSEME tag for several weeks and the date in the tag is far gone. If the reporter can still see this issue, Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). Then please remove the closeme tag in the whiteboard, mark the bug against the proper version and comment on the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

7 years ago
I tried with Firefox 3.6.15. The issue still remains unsolved.
No modification seems to have been made.

However, I am now using Firefox 4 beta 11 mainly.
It doesn't have this issue.

If nobody else is annoyed, I don't wish this issue to be fixed.

I'm not sure which status to choose.
Status: RESOLVED → VERIFIED
Resolution: INCOMPLETE → WONTFIX
Version: 3.5 Branch → 3.6 Branch
You need to log in before you can comment on or make changes to this bug.