deletion of bullet list content does not delete all bullet items

VERIFIED FIXED in mozilla0.9.2

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: rubydoo123, Assigned: Joe Francis)

Tracking

({helpwanted})

Trunk
mozilla0.9.2
x86
Windows 98
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [list][QAHP])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
1.open composer
2.insert list, make sure you have at least 3 list items, add text to each list 
item
3.highlight all of the text in the list, press any key

what happens: one of the additional bullet items remains, instead of just the 
first item

expected: only the first list item should remain
(Reporter)

Comment 1

18 years ago
setting to m19
Target Milestone: --- → M19
(Assignee)

Comment 2

18 years ago
accepting this bug as if it were my own son.  which it is.
Status: NEW → ASSIGNED
(Assignee)

Comment 3

18 years ago
sometimes this happens, sometimes it doesnt.  i believe what's happening is this: 
if the last list item has a trailing br, you wont see it (the br ends a line but 
does not cause a new line: you need more text after it or another br for that to 
happen).  When you select sometimes you end up selecting that last be and 
sometimes you don't.  When you dont, it ends up in a list item all by itself, 
like it should.  The real problem is that there is no way for the user to see the 
br, or know if it's selected.

cc'ing mike.  Mike, i think if you drag select past a text node, going below and 
to the right of it, you sometimes don't get the br following it selected.  Maybe 
we should always select it in that case.
(Assignee)

Comment 4

18 years ago
mike and i stepped through this.  It's true that depending on how you do the 
selection, you get a subtly different selection range.  But the deletion code 
should bahve the same way for the two different possibilities, so this is 
definitely my bug.  I'll try to fix this during the b3 "quiet period", though I 
doubt anyone will let me check it in.
(Reporter)

Comment 5

18 years ago
setting to future, adding helpwanted
Keywords: helpwanted
Target Milestone: M19 → Future
Keywords: mozilla1.0
(Reporter)

Comment 6

17 years ago
*** Bug 71875 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Whiteboard: [QAHP]
(Reporter)

Comment 7

17 years ago
moving to moz0.9.2 per triage meeting
Target Milestone: Future → mozilla0.9.2

Comment 8

17 years ago
Created attachment 33188 [details]
sweet testcase

Comment 9

17 years ago
open the testcase above in composer, highlight all of the text with mouse and 
press any character key on keyboard. Observe that the first item stays but 
another empty list item stays there too.
(Reporter)

Updated

17 years ago
Whiteboard: [QAHP] → [list][QAHP]
(Assignee)

Comment 10

17 years ago
fixed by my changes in 091
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
yeah, veirifed fixed on 0523. Testcase works fine now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.