Date() returns incorrect value (related to shunt)

RESOLVED WONTFIX

Status

()

P1
normal
RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: beltzner, Unassigned)

Tracking

Trunk
x86
Windows CE
Points:
---

Firefox Tracking Flags

(fennec1.0-wm+)

Details

(Whiteboard: [nv])

STR:

1. Double check system time
2. Open a new tab
3. javascript:(new Date())

Expected: same time as system thinks
Actual: a bizarro time (mine was GMT +2000, which doesn't exist)

Vlad suggests that this is a shunt problem. Apparently those words mean something, perhaps even something related to:

http://hg.mozilla.org/mozilla-central/file/d743242a080a/build/wince/shunt/time.cpp

Another way to notice this if you have a Zimbra account is to run a WinCE build and try to use your Zimbra Calendar. It's koo-koo-krazee!
Whiteboard: [nv]
Possibly related to bug 503710?
Perhaps even a dupe, yeah. It does look like we're just not formatting the offset correctly.

Updated

9 years ago
tracking-fennec: ? → 1.0-wm+
Mine reports "GMT +1700", instead of "GMT-0700". Interestingly, I think that's correct relative to you, and the total is 24. Seems like something is getting a sign wrong somewhere.

Indeed (new Date()).getTimezoneOffset() reports -1020 on WinCE, but 420 on OS X.

So not a dupe of the other bug, but I will not be shocked if the fix still ends up being in the shunt code.
Mike, do you still see this?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.