If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Restoring tabs if there was "no tab" (means a empty tab) in the last session (keywords: firefox 3.5.1 session restore no empty tab )

RESOLVED DUPLICATE of bug 495123

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 495123
8 years ago
8 years ago

People

(Reporter: Tarek.Chebbi, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

ATTENTION:
Tab Restoring has to be enabled in the options of course!

If you have no tabs in your Firefox 
(means:
- close all tabs until there is only one(I name it TAB-A from here on)
- create a new one
- close the other)
and then restart Firefox(or close and open it again ;) )

A)
it will tell you SOMETIMES:
that that what happened shouldnt have happened and it asks if and if yes which tabs you would like to restore
(you will have the choice between TAB-A or nothing(for additional infos on TAB-A read above))

or B)
it restores TAB-A(for additional infos on TAB-A read above)

PROBLEM:
TAB-A was closed in the last session and there was only a empty tab left.
But it seems Firefox cant restore empty Tabs

Reproducible: Always

Steps to Reproduce:
1.Close all Tabs, and create a "empty tab" (means: open a new tab and close all other)
2.Shut down Firefox and start it again
Actual Results:  
The tab, which was the last to exist(before the empty tab was created) was restored

OR

Firefox says that "that what happened shouldnt happen" and asks if it should restore the tab that was the last one to exist, before the empty tab was created
(in the last session)

Expected Results:  
Restore a empty tab

-no theme used,
-all add-ons temporarily shutted down
(Reporter)

Updated

8 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Comment 1

8 years ago
UPDATE:
Reproducible: Sometimes

sry havent seen that option!

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 495123
You need to log in before you can comment on or make changes to this bug.