No localisation for File Upload UI elements

RESOLVED INVALID

Status

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: lakotam, Assigned: rpmdisguise-nave)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.12) Gecko/2009070611 Firefox/3.0.12 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.12) Gecko/2009070611 Firefox/3.0.12 (.NET CLR 3.5.30729)

Spanish OS, FF with spanish localisation. Open any site(application) in spanish where file upload ui elements are used. The button Browse is not localised. 

Reproducible: Always

Steps to Reproduce:
1. Spanish FF 3.5.1
2. Spanish OS
3. Go for example to Facebook -> Photos -> Add photos

Actual Results:  
File Upload UI elements has button Browse.

Expected Results:  
The button name should be localised.
(Reporter)

Comment 1

9 years ago
Created attachment 391905 [details]
FileUpload elements are not localised
Assignee: nobody → rpmdisguise-otros
Component: General → es-ES / Spanish
Product: Firefox → Mozilla Localizations
QA Contact: general
(Assignee)

Comment 2

9 years ago
(In reply to comment #0)
> Spanish OS, FF with spanish localisation. Open any site(application) in spanish
> where file upload ui elements are used. The button Browse is not localised. 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Spanish FF 3.5.1
> 2. Spanish OS
> 3. Go for example to Facebook -> Photos -> Add photos
> 
> Actual Results:  
> File Upload UI elements has button Browse.
> 
> Expected Results:  
> The button name should be localised.


Guillermo, I don't have a Facebook account, could you test that page in several browsers? I've visited http://imageshack.us/ and the Browse... button is correctly translated to Examinar... Also, I couldn't find any "Browse..." appearance in the es-ES side using French Glossary Tools:

http://www.frenchmozilla.fr/glossaire/es-ES/index.php?recherche=Browse

So I'd say this bug is a WORKSFORME, but I need further confirmation.
WORKSFORME in MacOSX.

Try to test later in Windows.
(Assignee)

Comment 4

9 years ago
(In reply to comment #3)
> WORKSFORME in MacOSX.
> 
> Try to test later in Windows.


Tested in Windows XP using Firefox 3.5.1 es-ES visiting two pages: http://www.imageshack.us/ and the upload attachment page of this very site (https://bugzilla.mozilla.org/).

To me, the problem is restricted to Facebook and specific of the site, not the browser. Guillermo, could you visit Facebook Add Photo page with a browser other than Firefox 3.5.x (Safari, Opera, SeaMonkey...) and report the language in which the Upload button appear? Thanks.
With Safari 4 and Opera it works perfectly.
(Reporter)

Comment 6

9 years ago
Created attachment 392242 [details]
Firefox settings

http://imageshack.us/  is in english
(Reporter)

Comment 7

9 years ago
Sorry, I gave you incorrect settings of FF. Bug is reproduced with the Ubuntu OS. See settings in the last attachment. The site http://imageshack.us/ we also have in english.
(Assignee)

Comment 8

9 years ago
(In reply to comment #7)
> Sorry, I gave you incorrect settings of FF. Bug is reproduced with the Ubuntu
> OS. See settings in the last attachment. The site http://imageshack.us/ we also
> have in english.


The language dialog you are displaying in the attachment 392242 [details] is not related to the program UI language, but to the languages sorted by preference you want to get web pages. In other words, if a website (like http://www.google.com/) can serve pages in several languages, Firefox will pass that list the server and it will return the first available version it has.

So, is that list relevant to the language a button is displayed? For a file upload button, usually not, because such button is defined like <input type="file" id="uploadedfile" /> and the button text is provided by the program UI, rather than the web page. Doing it in a different way would probably imply a lot of JavaScript code.

Now, I've tested on my Ubuntu machine, and I really think you are not using an es-ES localization. Please, go to location bar and type:

about:

and press Enter. Then compare your results with the image I'm about to attach to this bug. Note also that I'm running Firefox 3.0.12, while you are in 3.0.11. It shouldn't make a difference, but just in case, try to upgrade.
(Assignee)

Comment 9

9 years ago
Created attachment 392266 [details]
Snapshot of Ubuntu Firefox 3.0.12 es-ES with the Browse... button correctly localized
(Reporter)

Comment 10

9 years ago
We've upgrated the version to 3.0.12 and changed some settings. Now the localisation is ok.
(Assignee)

Comment 11

9 years ago
(In reply to comment #10)
> We've upgrated the version to 3.0.12 and changed some settings. Now the
> localisation is ok.


So, it actually was not a problem in the es-ES official Mozilla localization. :-) Closing as Invalid, which I think is the closest to what has happened.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.