Firefox 3.7a1pre cannot play back very small ogg/vorbis files

RESOLVED DUPLICATE of bug 501545

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 501545
9 years ago
2 years ago

People

(Reporter: Daniel Holth, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

Firfox 3.1.5's <audio> tag doesn't seem to work with very small ogg/vorbis files (14k or less) served from the Cherokee web server. Perplexing!



Reproducible: Always

Steps to Reproduce:
1.Download http://dingoskidneys.com/~dholth/audio/00013.ogg (lighttpd)
2.Serve on Cherokee 0.99.10 in its default configuration (I do not have a public Cherokee web server, sorry)
3.Visit with Firefox 3.1.5
4.No playback

Compare with 00014.ogg (30kB, works); 00016.ogg (14k) is also broken.


Expected Results:  
I expected to hear something or at least get an error event from the DOM.

Comment 1

9 years ago
Can you download the file with no error?
Have you tried safe mode?
(Reporter)

Comment 2

9 years ago
I tried safe mode and I tried asking the IRC channel to play the same file. The small files did not play in either case.

A Firefox 3.6 build fixed the problem for one tester.
(Reporter)

Updated

9 years ago
Summary: Firefox 3.1.5 cannot play back very small ogg/vorbis files served by cherokee → Firefox 3.5 cannot play back very small ogg/vorbis files served by cherokee
(Reporter)

Comment 3

9 years ago
I can download the file with no error and the files are identical from both servers according to diff.

The MIME type is either application/ogg or audio/ogg. Clearing the browser cache and restarting the browser after reconfiguring Cherokee to use the other MIME type does not fix the problem.
looks like a dupe of bug 501545
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 5

9 years ago
May be a dupe. I'm not really sure why FF can't play only some of my files. Try this fun demo:

http://dingoskidneys.com/~dholth/clock/

It should play all the digits from 0-10 in succession but it skips most of them. No real talking clock until the <audio> tag works, sorry. All the oggs were encoded at the same time with oggenc *.wav, ogg123 plays them back fine and so on. They are smaller in kb than the other files I was playing with.

Comment 6

9 years ago
This sounds like a duplicate of bug 501708. That one is fixed.
So please confirm and close this one.
(Reporter)

Comment 7

9 years ago
Downloaded the Win32 .exe installer from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ this morning and it's still broken.

For example, it can't play this file.

http://dingoskidneys.com/~dholth/clock/digits/1.ogg

No sound in FF

Plays fine in e.g. VLC, Chrome. (Chrome can't play the whole page, but that may just be a bug in my JavaScript).

Forget what I said about Cherokee. It looks like the web server doesn't make any difference.
Summary: Firefox 3.5 cannot play back very small ogg/vorbis files served by cherokee → Firefox 3.7a1pre cannot play back very small ogg/vorbis files

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501708

Comment 9

9 years ago
er. dupe the bug to the open issue from comment 4.
Duplicate of bug: 501545
You need to log in before you can comment on or make changes to this bug.