TM: Different values with testcase containing for, function

RESOLVED DUPLICATE of bug 507053

Status

()

RESOLVED DUPLICATE of bug 507053
10 years ago
7 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 2 bugs, {testcase})

Trunk
x86
Mac OS X
testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
let(f = function () {
    let b = (function () {
        for (a = 0; a < 3; ++a) {
            b = a
            print(b)
        }
    })()
}) {
    f()
    f()
}

outputs different results on TM branch with and without -j. Doesn't seem to affect 1.9.1 branch.

===

$ ~/Desktop/tm-30811-b8cc6ff9d6dc/js-opt-tm-darwin 
js> let(f = function () {
    let b = (function () {
        for (a = 0; a < 3; ++a) {
            b = a
            print(b)
        }
    })()
}) {
    f()
    f()
}
0
1
2
0
1
2
js> 

$ ~/Desktop/tm-30811-b8cc6ff9d6dc/js-opt-tm-darwin -j
js> let(f = function () {
    let b = (function () {
        for (a = 0; a < 3; ++a) {
            b = a
            print(b)
        }
    })()
}) {
    f()
    f()
}
0
1
2
undefined
undefined
undefined
js>
Flags: blocking1.9.2?
This seems to have been fixed by this changeset:

changeset:   30813:be4280409fb3
user:        David Mandelin <dmandelin@mozilla.com>
date:        Thu Jul 30 11:34:35 2009 -0700
summary:     Bug 507053: fix on-trace scope chain computation for JSOP_BINDNAME, r=gal
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 507053
By the way, I like the way your test output in this bug report shows what rev you were testing with. Very helpful.
(Reporter)

Updated

10 years ago
Flags: in-testsuite?
Dupe of blocking.  Clearing flag.
Flags: blocking1.9.2?
(Reporter)

Updated

7 years ago
Blocks: 349611
You need to log in before you can comment on or make changes to this bug.