Create tests for Search Add-ons

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: rjwalsh, Assigned: rjwalsh)

Tracking

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

9 years ago
The add-on framework does not currently have tests for search engines.  There are two tests specified in the spec however, located here: 
http://docs.google.com/Doc?id=dcfr9qrp_1c2pgcsfh
(Assignee)

Comment 1

9 years ago
Created attachment 391962 [details] [diff] [review]
Search engine tests

Tests for search engines
Attachment #391962 - Flags: review?(clouserw)
(Assignee)

Comment 2

9 years ago
Created attachment 391968 [details] [diff] [review]
Patch with descriptions on validation.thtml

Same as before, but with info for validation.thtml
Attachment #391968 - Flags: review?(clouserw)
(Assignee)

Updated

9 years ago
Attachment #391962 - Attachment is obsolete: true
Attachment #391962 - Flags: review?(clouserw)
(Assignee)

Comment 3

9 years ago
Created attachment 392286 [details] [diff] [review]
Fixes some fropblems with previous patch
Attachment #391968 - Attachment is obsolete: true
Attachment #392286 - Flags: review?(clouserw)
Attachment #391968 - Flags: review?(clouserw)
Comment on attachment 392286 [details] [diff] [review]
Fixes some fropblems with previous patch

Please add a migrations sql script too.
Attachment #392286 - Flags: review?(clouserw) → review+
(Assignee)

Comment 5

9 years ago
Fixed in r48440 and r48441 (migration)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

9 years ago
Created attachment 392519 [details] [diff] [review]
Fixes errors caused by previous patch

Fixes broken tests on non search-engines
Attachment #392519 - Flags: review?(clouserw)
Comment on attachment 392519 [details] [diff] [review]
Fixes errors caused by previous patch

Thanks.  Please commit asap
Attachment #392519 - Flags: review?(clouserw) → review+
(Assignee)

Comment 8

9 years ago
Second patch in r48588
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.