Plug-in get re-initialized when CSS attribute overflow: hidden is removed.

RESOLVED DUPLICATE of bug 90268

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 90268
9 years ago
8 years ago

People

(Reporter: Move Networks, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; en-us) AppleWebKit/530.19.2 (KHTML, like Gecko) Version/4.0.2 Safari/530.19
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.12) Gecko/2009070611 Firefox/3.0.12

Hiding a DIV that contains the Move Media Player object in various ways causes Firefox to re-initialize our plug-in after it is again shown. Some of the ways that we have experienced issues are by using CSS attributes of:

overflow: hidden
display: none
width: 0px
height: 0px

When any of these attributes are used to hide an HTML element that contains our plug-in when those attributes are reset/removed then our plug-in gets re-initialized by Firefox. This happens on Firefox 2-Firefox 3.5.

Using the CSS attribute of visibility: hidden works as expected.

Reproducible: Sometimes

Steps to Reproduce:
1. Make sure Move Media Player plug-in is not installed
2. Go to the URL mentioned in this bug. (http://research.movenetworks.com/bugs/mozilla/install/)
3. Download and install the plug-in
4. Post-install video does not display due to plug-in being re-initialized after displaying the parent DIV. (Likely you will experience a JavaScript error from trying to access attributes/methods of the plug-in that don't exist until after the plug-in has finished initializing.
Actual Results:  
Plug-in is re-initialized

Expected Results:  
Plug-in should not be re-initialized. Told to re-paint sure, re-initialize...no.
dupe/related to bug 502753

Updated

8 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90268
You need to log in before you can comment on or make changes to this bug.