Every bookmark I click on that goes to download.cnet.com freezes Firefox.

RESOLVED DUPLICATE of bug 506428

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 506428
9 years ago
9 years ago

People

(Reporter: JessicaR62288, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

I just installed Firefox on this PC.  I imported my bookmarks, etc. from IE7.  I then started going through and organizing my bookmarks clicking one at a time down the list.  Everything is opening fine with one exception.  Each bookmark I clicked on that was to a download.cnet.com page caused Firefox to freeze immediately after the page loaded.  I was not able to select a different tab or to select a different bookmark.  I then right clicked on the Firefox button on the task bar and selected "close" (the only option available).  The window went white and then closed.  Upon reopening Firefox, it froze again immediately because I have Firefox set up to open all tabs from the last session.  After another attempt to reopen, Firefox gave me the option to close one or more of the tabs from the previous session or start a new session.  I chose to close only the tab with the download.cnet.com page loaded and Firefox opened just fine.  This happened on probably 6 bookmarks as I went down my list and the common denominator of all of them was download.cnet.com.

Reproducible: Didn't try

Steps to Reproduce:
1. I pretty well described what happened in the details section above.  I did not uninstall/reinstall Firefox, reimport bookmarks from IE7, and attempt to go to the bookmarked pages.
2. I thought that the realization that every bookmark to the same domain froze the software was enough of a reproduction.
3.


Expected Results:  
Open the page without freezing.

This is a fresh install of Firefox 3.5.1 on this PC.  No previous versions of Firefox had been installed on it.  No add-ons or themes have been installed yet.  The only thing I did was import info from IE7 during installation then changed a few options and stared clicking through and refiling the imported bookmarks.

Comment 1

9 years ago
Do freezing pages contain many checkboxes? If so, it is bug 477564.
	
And do you have an exact link of a freezing page?

Lucas
The site can hang if you don't allow cookies. Is that the case? Then dupe this bug to 506428.

Comment 3

9 years ago
bug 506428 (clickable :-).
(Reporter)

Comment 4

9 years ago
The pages that make it freeze do not contain checkboxes.  They are individual pages for software downloads from download.com with the description of the software.  I included a link as an example when I completed your form but I'll include a few examples here.

http://www.download.com/Eusing-Free-Registry-Cleaner/3000-2094_4-10521691.html?tag=mncol&cdlPid=10814544

http://www.download.com/Glary-Registry-Repair/3000-2086_4-10372101.html?tag=mncol&cdlPid=10876678

http://www.download.com/System-Explorer/3000-2094_4-10784281.html?tag=mncol&cdlPid=10878396

After the page loaded, it wasn't simply that the page froze and I could keep working on other tabs or clicking on other links.  The program itself froze (went not responding).  I accidentally clicked on one of the links when I was responding to this a few minutes ago when I meant to right click and it of course froze again and I lost what I had typed to you.  That time I didn't close the program myself.  I walked away from the PC to do something.  When I came back, Firefox had closed and showed a msg apologizing for the inconvenience and asking if I wanted to send an error report to Mozilla with the link I was on.  I opted not to do that since I already have this report going.

Regarding cookies, I do not accept cookies from most sites.  Firefox is not freezing on other sites though even when cookies are not accepted, only those from the download.com domain which I found odd.  That's why I'm reporting.  Normally I wouldn't bother but I've used Firefox and I prefer it over IE so I thought I'd try to help.  Anyway, not accepting cookies should not cause the entire program to freeze up.  It's not simply the case of a page hanging.  I have other tabs open that I can't access.  It also won't allow me to click on any other bookmark or go back to the previous page.  The program does not respond and must be closed and reopened.  Upon reopening, it freezes again because it goes back to the page that caused the issue.  After closing the program another time or two I try again and I get a report of the tabs I had open in the previous session and the opportunity to either close any of those tabs that might be causing the problem before restarting Firefox or starting a new session.  Obviously Firefox itself recognizes that there was a problem.

I hope this has been helpful.

Comment 5

9 years ago
Thanks for the information. Indeed, the browser should behave properly when cookies are disabled. Problem with a bug like this, is first to reproduce it. And it seems, that it only reproduces with cookies disabled.

So, I think this indeed a dup of bug 506428. Maybe I will take a look at it next week (after 3.5.2 has been released), but I am only a volunteer.

Comment 6

9 years ago
I can confirm this problem, when I disable cookies, specific for that site.

Jessica, as work around, turn on the cookies for cnet.com.
In options menu and privacy, you can turn on/off cookies for specific sites.

I mark this as duplicate of 506428. Behavior of FF is odd.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 506428
You need to log in before you can comment on or make changes to this bug.