JavaScript alert() or confirm() while dragging tab prevents any mouse control

VERIFIED DUPLICATE of bug 100180

Status

()

Core
Event Handling
VERIFIED DUPLICATE of bug 100180
9 years ago
6 years ago

People

(Reporter: tsukasakun, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

If a JavaScript alert(), confirm() or any other such dialog pops up while you are dragging a tab (before releasing), you lose all mouse control over Firefox (literally NOTHING works).

However, focus is on the alert() or confirm() dialog and the keyboard still works, so you may use the keyboard to dismiss the dialog and release Firefox from the lock.

I wasn't sure whether to file this under Minor or Normal, since an easy workaround IS present (using the keyboard), but when this happened to me the first time I did not consider this, since Firefox appeared to be completely locked. I only attempted using the keyboard when trying to reproduce the bug. Also, this is not "a minor loss of function".

Reproducible: Always

Steps to Reproduce:
Create a new HTML page composed of the code from the Additional Information filled.

Click one of the links to initiate the timeout, and then begin dragging a tab (having only one tab open is okay too - you can just drag that one). Keep the tab on your mouse until the JavaScript dialog pops up. Once it pops up, you can let go.

Remember, you can use the keyboard to control the JavaScript dialog.
Actual Results:  
I was unable to "drop" (let go) of the tab anywhere, even after releasing the mouse button. I was unable to click on any of the buttons on the confirm() or alert() dialog.

Expected Results:  
Since I had not yet "dropped" the tab, it should have returned to its original position since the drag & drop was interrupted.

<a href="javascript:void(setTimeout('alert(\'Did you reproduce the bug?\')', 5000))">Click me to trigger a 5 second 

wait, and then a alert() window</a>
<br>
<a href="javascript:void(setTimeout('confirm(\'Did you reproduce the bug?\')', 5000))">Click me to trigger a 5 second 

wait, and then a confirm() window</a>
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch

Updated

9 years ago
Component: Tabbed Browser → Event Handling
Product: Firefox → Core
QA Contact: tabbed.browser → events
Version: 3.5 Branch → 1.9.1 Branch

Comment 1

7 years ago
Duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=100180
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 100180
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.