Firefox does not close properly, high cpu usage after close

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: michal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; pl-PL; rv:1.9.1.1) Gecko/20090717 Fedora/3.5.1-3.fc11 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; pl-PL; rv:1.9.1.1) Gecko/20090717 Fedora/3.5.1-3.fc11 Firefox/3.5.1

When i close Firefox it still is shown under processes list using 100% CPU. Sometimes, this happens randomly it just sits there not using any cpu bot blocking from opening new firefox.
I do not have to open any new pages, it sometime happens just after opening Firefox.

Reproducible: Sometimes

Steps to Reproduce:
1.Open Firefox
2.Close Firefox

Actual Results:  
firefox still running but no firefox window visible.

Expected Results:  
Should close all processes
(Reporter)

Comment 1

9 years ago
I am sorry, forgot to mention that this happens in safe-mode and with new profile.
Are you using the latest plug-ins (especially java and flash)?
(Reporter)

Comment 3

9 years ago
Yes i am, after you mentioned it i`ve run firefox -safe-mode and disabled all plugins. Still same problem occurs.
Do you still see this with the latest build? Trunk nightlies contain the latest fixes. http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
To prevent possible profile corruptions, test it with a new profile.
(Reporter)

Comment 5

9 years ago
Yes it does.
I downloaded http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-3.6a1pre.en-US.linux-x86_64.tar.bz2

Created new profile and named it 'test'. Then i ran firefox from extracted directory by issuing './firefox -P test'.
As i noticed there were no plugins at all, no add-ons, nothing. Still same error.
Same problem here.

That problem happened in both Firefox 3.0 and 3.5, and either in Arch or Kubuntu, but only in the 64-bit version.
But I guess the problem is on Xulrunner, since another browser based on it (conqueror, I guess) had the same problem.

Comment 8

9 years ago
I have the same issue on Firefox 3.5 and 3.6b4 on ArchLinux 32bits.

Comment 9

9 years ago
(In reply to comment #8)
> I have the same issue on Firefox 3.5 and 3.6b4 on ArchLinux 32bits.

I recently change my gtk-qt-engine from kde style to qtcurve and the problem seems no longer happen.

Comment 10

9 years ago
Same problem under Windows 7 Professional 64bit with Firefox 3.5.7

Comment 11

9 years ago
I have the same issue with Windows 2000 and Firefox 3.5.7 but only with the close button on the top right of the screen. Except mine seems to reproduce almost all the time.

Comment 12

9 years ago
I have the same problem sometimes with Firefox 3.6!

But most times it work
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]

Comment 14

8 years ago
With Firefox 3.6.13 it works fine for me!
Even if I'm not in safe mode.

Thanks for your effort!

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.