<audio> stops after 2 seconds

RESOLVED DUPLICATE of bug 506061

Status

()

RESOLVED DUPLICATE of bug 506061
9 years ago
9 years ago

People

(Reporter: expensivelesbian, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090801 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090801 Minefield/3.6a1pre

with a simple page containing an <audio> element, and a button calling the play() action via the DOM, the audio starts, then stalls at 2 seconds. Doesn't seem to happen with the 3.5.x branch. markup is a very simple

<audio id="audioTestElem" controls="" autobuffer="">
<source type="audio/ogg; codecs=vorbis" src="test.ogg"/>
<source src="test.m4a"/>
no audio for you
</audio>

button is a simple, <button onclick="document.getElementById('audioTestElem').play()">Play</button>

the bug happens using the play button offered via the controls also.

Reproducible: Always

Steps to Reproduce:
1. create a simple audio test page, as given in the details above.
2. click "play" either by the bespoke button, or on the controls UI.
3. scrubber gets to 2 seconds and then stalls/stops/doesn't move.
Actual Results:  
scrubber gets to 2 seconds and then stalls/stops/doesn't move.

Expected Results:  
for the audio element to play the stream without pause, until the user invokes a request that would stop playback.

I haven't managed to test this outside of Linux (Ubuntu Karmic), so I can't currently confirm if this is a platform specific issue. If there's more info I can provide, please let me know.
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
this appears to have gone away now.

Comment 2

9 years ago
I'm also having problems with the <audio> element. The first time I load a page, the sound stutters, and after a few refreshes it normally stops after a few seconds. These problems happen in both 3.5.x and the latest daily on Ubuntu 9.10.

I've gotten a test site here: http://www.xs4all.nl/~pineau/test_audio/

To reproduce the problems:
1. Load the page.
2. If the audio plays normally, refresh.

Comment 3

9 years ago
I'm still experiencing this bug and if this problem persists, i'll have to use the IE solution for a site i'm developing (i.e. flash). I'm able to reproduce this problem on both Ubuntu 9.04 and 9.10.

Comment 4

9 years ago
Possibly bug 506061. Are you still experiencing it on trunk?

Comment 5

9 years ago
I am using the Mozilla Daily PPA (https://launchpad.net/~ubuntu-mozilla-daily/+archive/ppa) and still experience the bug in firefox 3.7. Can no one confirm this bug?
(Reporter)

Comment 6

9 years ago
Hi, I'm playing <audio> on Firefox 3.7 nightly now and it seems to be playing fine, with no interruptions, or stalling on load. I could never reliably reproduce the errors in this ticket anyways, but things seemed to get better/worse/better again as the ALSA and PulseAudio updates happened via update manager.
Since you're no longer seeing this, and similar symptoms have been fixed by another bug, I'm marking this as a dupe of that.  Please file a new bug if you're still experiencing problems.  Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 506061

Comment 8

9 years ago
In Camino play all and individual play at this site http://www.cbc.ca/radio2/cod/concerts/20081103const#at worked fine for about 24 hours. Then only the first two seconds oh each track (play all) in succession or the first two seconds of any individual track play at all. Firefox won't play any track and generates an error dialog. However, save link a in firefox creates an .asx audio file which plays correctly in Flip4Mac Quicktime.
This bug is specifically about audio problems with the HTML 5 video/audio elements.  As far as I can tell, that site relies on proprietary plugins to play audio in an ASX container, so if you're having trouble it may be with the plugin you're using to play the content, or a bug in Firefox's plugin handling--either way, it's not this particular bug.  Please file a new bug for your issue.
You need to log in before you can comment on or make changes to this bug.