no way to choose "paste" in virtual keyboard (vbk) options if awesome bar is selected

RESOLVED DUPLICATE of bug 449895

Status

Firefox for Android Graveyard
General
RESOLVED DUPLICATE of bug 449895
9 years ago
8 years ago

People

(Reporter: Uwe Kaminski, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: fennec nightly build 20090801 on Maemo 4.3.1 (5-2008.43-7)

In the bottom left corner of the vbk in maemo you can find some functions like:
* copy
* cut
* paste
* [and some others]
They can't be selected if awesome bar is selected.

Reproducible: Always

Steps to Reproduce:
1. start fennec
2. tip into the awesome bar
3. tip into the bottom left corner of virtual keyboard to get vbk functions
Actual Results:  
The functions dialogue comes up but only for a very short time ( < 0.5 seconds) and it's not possible to select one of the functions.

Expected Results:  
functions dialogue should be displayed until the user is tipping on an other area on it's tablet window.

It's very annoying because I can't use fennec as standard browser which will come up if I select a link in an other application (link in an email for example). So the only possibility would be to copy and paste the link into the awesome bar. Both is impossible at the moment...
The root problem of this bug is that fennec cannot be set as the primary browser on maemo. There's a bug on hand for this that was created before this one. I'm setting this as a duplicate of bug 490189.

If this problem is still going on after the primary bug is fixed, then please re-open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 490189
My opinion is this bug absolutely can not be a duplicate for bug 490189.
They might be somewhat related, but are of completely different nature.

Inability to paste URL into the awesome bar is a real separate issue. Making Fennec a default browser should help in some cases, but not always. There still could be a lot of situations when the URL needs to be copied&pasted.
i also believe they are not dup (nor possible dependent)

gtk has to be hooked in order to make paste/copy/cut to work w/ its vkb
If your main issue is for copy and paste, then this is a duplicate for bug
449895
Duplicate of bug: 449895
(In reply to comment #4)
> If your main issue is for copy and paste, then this is a duplicate for bug
> 449895
> 
> *** This bug has been marked as a duplicate of bug 449895 ***

i also do not think it is a dup of this one.

bug 449895 is mostly concerned about clipboard via physical keyboard, which can work and clipboard via softbk still do not.
(In reply to comment #3)
> i also believe they are not dup (nor possible dependent)
> 
> gtk has to be hooked in order to make paste/copy/cut to work w/ its vkb

Antonio - Do you have any pointers (links or docs) we could use to hook up the vkb menu options?
hey mark, some docs here:

http://maemo.org/api_refs/4.0/gtk/GtkIMContext.html#GtkIMContext-has-selection

see "has-selection" and "clipboard-operation" signals iirc

i am try to come up w/ a patch later this week if none do this before.

again, imho it is not a dup but a blocker bug of bug 449895 instead

Updated

8 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
Hardware: Other → ARM
You need to log in before you can comment on or make changes to this bug.